Using FULLSCREEN with autohide of TASKBAR causes malfunction of STATUSBAR

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: J, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

Hi,

I have recently moved to a netbook, and require every vertical pixel possible for browsing. I thus have set my taskbar (start menu bar) to auto hide.

I then tried to use Firefox in fullscreen mode by hitting F11 (with autohiding fuctions of addressbar, taskbar, tabs etc turned ON). It causes a glitch where the status bar of Firefox is frozen, as though the region where the taskbar has minimised is not refreshed. Essentially this means that the status bar (or at least a frozen version of it) does not get hidden, eating up screenspace.

One option to prevent the frozen status bar is- to turn the autohide of the taskbar off from within the OS menu, but this is undesireable as:
1. the fullscreen mode of FF then prevents the taskbar popping up on mouseover
2. I want my taskbar autohiding for all my programs, not just FF.


Before I got a netbook, I didn't really see what the GoogleChrome developers where trying to achieve by "making the browser interface fall into the background" and dedicating more screen to the actual webpage, but seriously, wow, when you have only 7" of vertical screen, you bloodywell notice that tab-bar and Filebar and statusbar in FF. 
Given that netbooks are becoming more common, and people are starting to desire maximum screenspace with minimum visible browser controls, I feel FF developers would be well advised to try to resolve this kind of glitch to prevent users migrating to other browsers that consume less screen real estate. 

I LOVE FIREFOX AND DONT WANT TO HAVE TO MOVE TO CHROME OR OPERA!!!!!

Reproducible: Always

Steps to Reproduce:
1. Select Windows task bar mode to "autohide"
2. Open Firefox and hit F11 for fullscreen mode
3. Mouseover taskbar until popup
4. Behold frozen statusbar eating up your screenspace BLARGGGGG!!!!
Actual Results:  
Statusbar frozen from when you hit F11

Expected Results:  
Taskbar to popup, and autohide. Status bar to remain hidden.

Comment 1

9 years ago
I can't even get the task bar to pop.  Is that what you actually meant instead of status bar being frozen? Does this happen in safe mode?  How about with the latest Firefox?

Comment 2

8 years ago
Resolving this bug as incomplete due to the reporter not providing more information as requested.  Please reopen this bug if you can still reproduce will the latest version of Firefox and if you can provide the information that was requested.

You can also seek support at http://support.mozilla.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.