If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TM: "Assertion failure: *regs.pc == JSOP_CALL || *regs.pc == JSOP_DUP, at ../jsinterp.cpp"

RESOLVED DUPLICATE of bug 485022

Status

()

Core
JavaScript Engine
P2
normal
RESOLVED DUPLICATE of bug 485022
9 years ago
5 years ago

People

(Reporter: gkw, Assigned: gal)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
__defineGetter__("x", function(y) { yield y; });
z = x;
[0 for each (a in [-1e81, 0, 0]) for each (w in z)]

Assertion failure: *regs.pc == JSOP_CALL || *regs.pc == JSOP_DUP, at ../jsinterp.cpp:6954 with debug js shell and -j on.

autoBisect shows bug 463238 or http://hg.mozilla.org/tracemonkey/rev/1c6be1c210b9 may be related:

The first bad revision is:
changeset:   26344:1c6be1c210b9
user:        Andreas Gal
date:        Fri Mar 20 18:52:11 2009 -0700
summary:     Support calling arbitrary JSFastNatives from trace (463238, r=brendan).
Flags: blocking1.9.1?

Comment 1

9 years ago
covered by browser tests for 

js1_6/Regress/regress-476655.js
js1_6/extensions/regress-455464-03.js
js1_6/extensions/regress-472508.js
js1_7/regress/regress-453051.js
js1_8/extensions/regress-452476.js
js1_8/regress/regress-457065-01.js

Comment 2

9 years ago
ditto (w/-j on both sets)

ecma/ExecutionContexts/10.2.1.js
ecma/ExecutionContexts/10.2.2-1.js
ecma/ExecutionContexts/10.2.2-2.js
ecma/Statements/12.6.3-12.js
js1_5/extensions/regress-436741.js
js1_8/extensions/regress-476427.js
js1_8_1/JSON/regress-458959.js
js1_8_1/decompilation/regress-353249.js

Updated

9 years ago
Assignee: general → gal
Flags: blocking1.9.1? → blocking1.9.1+
(Assignee)

Comment 3

9 years ago
debug only. fix in a sec.
Severity: critical → normal
Priority: -- → P2
(Assignee)

Comment 4

9 years ago
Created attachment 369103 [details] [diff] [review]
patch

Due to bug 474854 pc is advanced when we see an exception, and a new imacro was added for NEXTITER that could stop on TRUE in this case (in addition to DUP).
Attachment #369103 - Flags: review?(brendan)
Attachment #369103 - Flags: review?(brendan) → review+
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 485022
(Assignee)

Updated

9 years ago
Attachment #369103 - Flags: review-
(Assignee)

Comment 6

9 years ago
Comment on attachment 369103 [details] [diff] [review]
patch

Patch no longer needed. Fixed by 485022.
(Reporter)

Updated

9 years ago
Flags: in-testsuite?
Bug in removed tracer code, setting in-testsuite- flag.
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.