Named anchor gets incomplete focus from in-page jump and no focus from out-page jump.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: davidm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

When Firefox jumps to a named anchor within the same page, the keyboard focus only partially moves to the target. The target is not rendered as having the focus and does not respond to the enter key. However, pressing tab moves the focus to the next item and, after this, shift-tab moves the focus back to the original target, where it now responds to the enter key. If the target named anchor is on a different page, the keyboard focus doesn't move to it at all but to the normal first focus item on the page. Internet Explorer works correctly in both circumstances. I first saw this in Firefox three years ago but assumed that it would eventually be fixed. It still exists in version 3.0.7. I have tried using name instead of id and adding tabindex (-1, 0, and 1) to no avail.
Example:
<div class="TaskBar">
<ul>
<li><a id="xzln" href="thumb.html#lnxz" title="To Multi-Level Thumbnails">
Next<img src="loright.gif" alt="" title="" class="LoNav" ></a></li>
</ul>
</div> <!-- End Taskbar -->
<p>
<a href="#xzln" style="text-decoration: none; white-space: nowrap;" >
Next<img src="loright.gif" alt="" title="" class="LoNav" ></a>

Clicking the <a href="#xzln" anchor causes Firefox to shift the display to the <a id="xzln" anchor but the keyboard focus moves incompletely.

Reproducible: Always

Steps to Reproduce:
1. Target is <a id="something" href="somethingElse"
2. Launcher <a href="something"
3. Click on launcher anchor
Actual Results:  
After clicking on the launch anchor the target is not rendered as having the focus and does not respond to pressing Enter. But it does respond to tab or shift-tab, correctly jumping to the next or previous page element. And once at either of this, reversing (shift-tab after tab or tab after shift-tab) takes the focus back to the original target, which now renders correctly and responds to Enter. This is the behavior when both the target and launcher are on the same page. If they are on different pages, the target does not get the focus when the launcher tries to jump to it.

Expected Results:  
In both in-page and out-page jump to named anchor, the target anchor should immediately be rendered as having the focus and should respond fully as having the focus, i.e. to Enter and not just to tab.

The problem has existed in Firefox for at least three years and has never existed in Internet Explorer or Safari. I have tried hard to find a workaround without success.
(Reporter)

Comment 1

9 years ago
FF 3.5.3 fixes this problem. I have tested in both Windows and Linux. Thanks to someone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
OK, it is WFM then, since we don't know what patch fixed it.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.