bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Downloading multiple files in quick succession breaks the "Save as" dialog.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: lasdka88+mozbugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729) FirePHP/0.2.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729) FirePHP/0.2.4

When I launched three sourceforge download pages in separate tabs in quick succession, one of the "Save as" dialogs was corrupted. After cancelling the broken "Save as" dailog, letting the other downloads finish and then retrying the download link - the "Save as" dialog was correctly presented.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Open these pages in separate tabs:
http://portableapps.com/apps/internet/filezilla_portable
http://portableapps.com/apps/graphics_pictures/gimp_portable
http://portableapps.com/apps/development/notepadpp_portable
2. Click the download button on each page in quick succession.
3. Check the "Save as" dialogs.
Actual Results:  
Two "Save as" dialogs appeared correctly, but the first of the files I clicked to download produced a corrupted "Save as" dialog. (Although I clicked on it first, it may not have been the first to download.) The file type and file location fields were blank, and the "Open with" drop down was located in the wrong place. 

Expected Results:  
Expected to get a simple "Save as" dialog for an Application, with options to Save and Cancel only.

I'll attach screenshots for a) the "Save as" dialog I actually got and b) the "Save as" dialog I was expecting.
(Reporter)

Comment 1

9 years ago
Created attachment 368862 [details]
Screenshot of the corrupted "Save as" dialog
(Reporter)

Comment 2

9 years ago
Created attachment 368863 [details]
Screenshot of the "Save as" dialog I was expecing to see.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 4

8 years ago
I can't reproduce this problem with Firefox 4.0b6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.