Session restore is not restoring most recent session after crash

RESOLVED DUPLICATE of bug 366509

Status

()

RESOLVED DUPLICATE of bug 366509
10 years ago
10 years ago

People

(Reporter: tpowellmoz, Unassigned)

Tracking

3.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Using 3.0.x (just happened with 3.0.7) I've experienced this multiple times: I browse for a while with multiple windows and tabs open, often for days or weeks at a time, then Firefox crashes. When it restores the session, it is from quite a while before. If I check the history, I see that the very latest visited sites are in the history, but the tabs and windows are not restored. I know for a fact that those tabs and windows were not closed but were not restored. I also know that some that were closed previously were (incorrectly) restored.

I have been unable to pin down specifics of what is getting restored. I don't think it is from the last clean quit. Most of the crashes leading to broken session restores have been random, perhaps memory-related -- they may occur after restoring the laptop from sleep and flipping through tabs.

I know this is terribly vague, but I did not see a bug about restoring what appears to be a PREVIOUS session. (I saw a number that point to specific cases where nothing is restored)

Other things that may or may not be relevant: I have Firefox set to show my windows and tabs from last time on startup. I frequently have to switch between using and not using a proxy (work vs. home). It is most likely that the only reason Firefox was previously shut down is due to a discovered upgrade (eg 3.0.5 to 3.0.6 to 3.0.7, etc.) In cases that I recall, the upgrade is properly restoring the session. I am a heavy browser user: I almost always have 15 to 30 windows open with 5 to 20 tabs in each.

Comment 1

10 years ago
This is happening to me on Vista 64. In my case I can tell whether a restore will work after the next crash because sessionstore.js is not being written while I'm browsing.

I originally reported it as bug 470355, but Firefox had stopped crashing for me at the time. Now it's crashing again.

Updated

10 years ago
Status: NEW → UNCONFIRMED

Comment 2

10 years ago
Probably the same issue as bug 480876. This could be either extension related or even be a variation of bug 406378 (i.e. your file system failing to write the current session to disk before the crash and then finding an intact older version instead).

Comment 3

10 years ago
Both of those bugs include the computer crashing.

I should have said that it either works or does not work for the entire session. It doesn't seem to write sessionstore.js for a while and then stop in the middle of a session. I usually look at the timestamp when I start Firefox.

And I'm getting these errors:

Error: [Exception... "Component is not available"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/components/nsSessionStore.js :: sss_saveState :: line 1909"  data: no]
Source File: file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/components/nsSessionStore.js
Line: 1909

Comment 4

10 years ago
Right, that's a Firebug related issue, then, which has been fixed for the upcoming Firefox 3.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366509
You need to log in before you can comment on or make changes to this bug.