too high cpu usage with opacity and animated gif

RESOLVED DUPLICATE of bug 595671

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 595671
9 years ago
7 years ago

People

(Reporter: csongor, Unassigned)

Tracking

({perf, regression})

6 Branch
x86
Windows XP
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

Opening the html file in the attached zip shows an animated progress bar with a table in the background. Firefox consumes almost 100% CPU (AMD Athlon 64 3000+, 2GB RAM). Opening the same html file with MSIE7 or Opera9.52 consumes almost no CPU resourses. 

If I cut out somthing from the html file then the CPU load becomes lower. For example omitting table borders of the cells decreses the load to ~90%. Removing only the opacity or only deleting the reference to the animated gif lets the CPU completely free again.

This means that animated backgrounds and opacity together wastes too much CPU time. 

Reproducible: Always

Steps to Reproduce:
1. open the html file
2. check if the progress indicator is animating
3. check that CPU usage is somewhere around 100% (btw. I use a single CPU system)
Actual Results:  
The CPU usage was ~100%

Expected Results:  
CPU usage should be below 10% (above 0 of course, because of other running system tasks)
(Reporter)

Comment 1

9 years ago
Created attachment 368893 [details]
illustration for the bug report. Contains the html and the gif file.

illustration for the bug report. Contains the html and the gif file.
Keywords: regression
Version: unspecified → Trunk
I get better results with Firefox 2 than with Firefox 3.
Whiteboard: DUPEME?
No, I can't find more information. Although I can see that the CPU is much higher with Firefox 3 and 3.5, the performance is quite acceptable on my Windows Vista computer and there are no slowdowns.
I only see a problem on my older XP laptop.

Updated

9 years ago
Severity: enhancement → normal

Comment 4

9 years ago
May be related to new FF 3.5 100% CPU with "screen shot" overlays, which also use opacity.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

To reproduce - goto URL: http://foxyproxy.mozdev.org/screenshots-2.7.2.html and click on any "screenshots". Images display slowly, cursor gets very-y-y lazy, 100% CPU for several seconds.  Consistently reproducible with other sites also.  New problem with 3.5; did not happen with 3.0.11.

Comment 5

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090925 Shiretoko/3.5.4pre GTB5

Windows XP SP 3

- html file:
firefox.exe's CPU usage was 70% - 80%. Quite high for such a simple page, IMO.

- http://foxyproxy.mozdev.org/screenshots-2.7.2.html
Cursor remains responsive. Images are a tad slow.
(Reporter)

Comment 6

8 years ago
With my new firefox the CPU consumption is much-much better then was before. Now it is about 15% instead of the original 100%. Athough, this is still too much, I think. MSIE 7.0 and Opera 10.0 uses less than 1% on the same machine.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You may also wish to try with the latest Firefox 4 beta, http://www.mozilla.com/en-US/firefox/all-beta.html.
Whiteboard: DUPEME? → [CLOSEME 2011-1-30]
(Reporter)

Comment 8

7 years ago
Hi, 

yes, the symptom is still present. 

As I mentioned on 2009-03-23 08:23:27 PDT, new FF versions are much better. Now CPU usage is about 10 percent, but Chrome on the same computer consumes 0% with this page so FF should be even less greedy.
(Reporter)

Comment 9

7 years ago
... even if we consider that such simple task really should not use CPU at all.
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 11

7 years ago
I tested it with a new profile as you asked. Now CPU usage is much better (~8%) although this is still mich higher then it should be. For example Google Chrome uses <1% in this case.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

7 years ago
Whiteboard: [CLOSEME 2011-1-30]
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110510 Firefox/6.0a1
Render 24 animated gif (smiles on vBulletin forum) - slow, FF eat ~20% CPU and heat nvidia graphics card to 5 degree.

Updated

7 years ago
Keywords: perf
Version: Trunk → 6 Branch
This bug is a duplicate of the bug 595671.
Please feel free to reopen the bug if you feel otherwise.
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595671
You need to log in before you can comment on or make changes to this bug.