All users were logged out of Bugzilla on October 13th, 2018

Intermittent failures ("Cc is not defined") in various downloads tests

RESOLVED DUPLICATE of bug 483200

Status

()

RESOLVED DUPLICATE of bug 483200
10 years ago
6 years ago

People

(Reporter: jag-mozilla, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
See e.g. http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1237812361.1237819338.32480.gz

*** 1348 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_retention_is_0_closes.xul | Error thrown during test: this.mDownload is null - got 0, expected 1
*** 1351 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_search_clearlist.xul | Error thrown during test: Cc is not defined - got 0, expected 1
*** 1354 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_search_clearlist.xul | Error thrown during test: Cc is not defined - got 0, expected 1
*** 1360 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_select_all.xul | Error thrown during test: Cc is not defined - got 0, expected 1
*** 1369 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_unkownContentType_dialog_layout.xul | Error thrown during test: Cc is not defined - got 0, expected 1
*** 1469 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/widget/tests/test_bug478536.xul | Error thrown during test: Cc is not defined - got 0, expected 1
*** 1640 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/widget/tests/test_wheeltransaction.xul | Error thrown during test: Cc is not defined - got 0, expected 1

The first one is bug 483200. Not entirely sure this is the right product/component, feel free to move it.
Component: Mochitest → Download Manager
Product: Testing → Toolkit
QA Contact: mochitest → download.manager

Updated

10 years ago
Whiteboard: [orange]

Comment 1

10 years ago
The reason of this failure is that the observer from test_retention_is_0_closes.xul still lingers around after that test is abruptly finished.  Now that the offending test has been disabled, this should no longer be an issue.

Resolving as a dupe of bug 483200.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483200
Version: unspecified → Trunk
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.