Got different result when I run the same js function twice.

RESOLVED DUPLICATE of bug 98409

Status

()

RESOLVED DUPLICATE of bug 98409
10 years ago
10 years ago

People

(Reporter: craigz, Unassigned)

Tracking

3.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

<script type="text/javascript">
function tclose(){
   if (notContainSpace('111 111')){
 	alert('no space!');
    }
}
 	 		
function notContainSpace(regValue) {
    var reg=/\s+/g;
    return ! reg.test(regValue);
}
</script>

run tclose() twice on a page, you will get different result.

Reproducible: Always
(Reporter)

Updated

10 years ago
Keywords: classic
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
Why did you set the classic keyword?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: classic
Resolution: --- → DUPLICATE
Duplicate of bug: 98409
You need to log in before you can comment on or make changes to this bug.