form fields are not submitted if the form itself is changed trough a javascript. (worked on previous versions of FF)

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: sharkyenergy, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

if there is a form, and you change the number of the fields of the form, based on a dropdown (for example you ask the nationality on a registration form and based on that you display or not the zip code) then the field that is, or is not displayed (<div></div>) does not submit its content.

simple schematic example:

<javascript>
funtion (update)
{
document.getElementById("test").innerHTML = '<input type="textbox" >'; 		
}
</javascript>

<form>
<input dropdown onchange="update">
<input textbox>
<div id="test"></div>
<input submit>
</form>


Please note that this example is just to show the page structure, it is not a working example to copy and paste..

Reproducible: Always

Steps to Reproduce:
1. create a form with a dropdown or any other action that can execute a javascript
2. add a javascript that changes a empty div to a new form field
3. execute the page, do the action needed to display the new field, submit the page
Actual Results:  
the data entered in the fields displayed by the javascript is not submitted. it worked properly on the previous version of FF (3.0.6) and works fine in internet explorer. so the page itself is ok.

Expected Results:  
the data should be submitted just normal

this bug is urgent, since it prevents proper registration on many sites.
First try the latest build, for maybe it is fixed: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.1/
and also test it with a new profile: http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

If the problem still occurs, can you give a link to a page with the problem, or, even better, upload a minimal testcase? Thanks!
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

9 years ago
Hi!

nothing fixed the problem. ill upload a testcase in a few hours.

thnx

igor
(Reporter)

Comment 3

9 years ago
HI everybody. i am terribly sorry! this is not a bug. i had a bug in the script, that for a strange reason worked with the previous version of FF and doesnt with this one. but the bug was on my end. i assumed the script was correct since it worked for over a year with all browsers. 

sorry again.

regards

igor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.