If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Sort by" order not kept when sharing profile cross-platform between Window and Linux

VERIFIED DUPLICATE of bug 351423

Status

Thunderbird
Folder and Message Lists
VERIFIED DUPLICATE of bug 351423
9 years ago
9 years ago

People

(Reporter: Edward Diener, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.21 (20090302)

I share my TB profile between Windows ( XP, Vista ) and Linux ( OpenSUSE, Fedora, Mandriva, CentOS ) by copying my profile data to a FAT32 partition folder and then pointing to that folder in my profiles.ini in each system. I can multi-boot my computer to these different OSs. I do not use these different OSs at the same time.

Everything works well except for the maintaining of the "Sort by" order for email accounts. For Windows systems originally I set the "Sort by" order for all e-mail accounts to "Date,Descending,Threaded". When I open TB under any of my Linux distros, the "Sort by" order for any of the e-mail accounts will always show "Date,Ascending,non-Threaded". I can reset it to "Date,Descending,Threaded" and this will hold while I am using the particular distro but as soon as I boot into another distro, the "Sort by" order will once again be reset to "Date,Ascending,non-Threaded".

This always happens no matter what Linux distro or Windows OS I have booted to. It appears that the full "Sort by" order is not being saved in the profiles directory but I am just guessing how TB works and what is causing this problem. Needless to say, this is an irritating TB bug which makes using TB cross-platform, using the same profile, very annoying.

Reproducible: Always

Steps to Reproduce:
1. Copy a TB profile to a directory which can be accessed cross-platform
2. Change profiles.ini to point to that directory
3. Boot the computer into a Windows OS and use TB.
4. Set the Sort by for an e-mail account to "Date,Descending,Threaded".
5. Boot the computer to a Linux OS and use TB.
6. You will see that the "Sort by" field for the e-mail account is set to "Date,Ascending,non-Threaded.
Actual Results:  
"Sort by" field for the e-mail account is set to "Date,Ascending,non-Threaded".

Expected Results:  
"Sort by" field for the e-mail account is set to "Date,Descending,Threaded".

The "Sort by" field for an e-mail account should remain the same across OSs using the same profile data.

Comment 1

9 years ago
Seems like bug 351423.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351423
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.