Closed Bug 485019 Opened 13 years ago Closed 13 years ago

Breakpad fails to compile on Linux with trunk GCC

Categories

(Toolkit :: Crash Reporting, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: jimb, Assigned: jimb)

Details

Attachments

(1 file)

When building with a GNU C++ compiler built from the latest public GCC sources, breakpad fails to compile.  Various source files use facilities declared in the <cstdio> header without #including that.  Sample error:

dump_symbols.cc
c++ -o host_dump_symbols.o -c  -I/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/../.. -I/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux -I.  -I../../../../../../dist/include   -I../../../../../../dist/include/breakpad_linux_common -I/home/jimb/mc/in/obj-bug/dist/include/nspr     -I/home/jimb/mc/in/obj-bug/dist/sdk/include -I/home/jimb/mc/in/obj-bug/dist/include/nspr /home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc: In function ‘bool<unnamed>::WriteFormat(int, const char*, ...)’:
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc:176: error: ‘vsnprintf’ was not declared in this scope
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc: In function ‘bool<unnamed>::ComputeSizeAndRVA(Elf32_Addr, <unnamed>::SymbolInfo*)’:
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc:487: error: ‘stderr’ was not declared in this scope
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc:487: error: ‘fprintf’ was not declared in this scope
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc: In function ‘bool<unnamed>::LoadSymbols(Elf32_Ehdr*, <unnamed>::SymbolInfo*)’:
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc:586: error: ‘stderr’ was not declared in this scope
/home/jimb/mc/in/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc:586: error: ‘fprintf’ was not declared in this scope
make[6]: *** [host_dump_symbols.o] Error 1
Attachment #369122 - Flags: review?(ted.mielczarek)
Assignee: nobody → jim
Status: NEW → ASSIGNED
Attachment #369122 - Flags: review?(ted.mielczarek)
I checked this in upstream. It'll have to wait for the next time we sync up with upstream to land in Mozilla. I don't like to keep bugs in bugzilla to track upstream issues, unless they're something really important to us.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Any idea when that next sync might be?  It's very helpful to be able to use trunk GCC for debugging (http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39496).
I've got nothing on the radar, although if you or graydon fixed bug 464750 and we landed it upstream, I would certainly sync up for that.
Duplicate of this bug: 488111
It might be worth leaving this bug open, because it doesn't show up in the default bug search (which only shows open bugs). Also, this bug in Mozilla has not been fixed yet, even if there is an upstream fix.
You need to log in before you can comment on or make changes to this bug.