Closed Bug 485073 Opened 12 years ago Closed 12 years ago

OS/2 enable test plugin equivalent to other platforms

Categories

(Core :: Plug-ins, defect)

x86
OS/2
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: wuno, Assigned: wuno)

Details

(Keywords: fixed1.9.1, Whiteboard: [fixed1.9.1b99])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.2a1pre) Gecko/20090323 Minefield/3.6a1pre
Build Identifier: 

I thought a while ago that we should use an equivalent test plugin like the other platforms. But getting the old one in bug471759 back to build properly. However, bug484137 removed the modules/plugin/tools directory, where we were the only left over consumer. So, now, it's time to get the new test plugin. I have already a patch more or less ready, but will attach it after checking it again.

Reproducible: Always
The code for the test plugin itself (nptest_os2.cpp) was copied from nptest_gtk2.cpp. It's a stub, but it compiles and builds a nptest.dll. Basically the bug here does the same as was done for the qt-build in bug474421
Assignee: nobody → wuno
Status: NEW → ASSIGNED
Attachment #369229 - Flags: review?(mozilla)
Comment on attachment 369229 [details] [diff] [review]
add a new test plugin
[Checkin: Comment 3]

Great!. As this doesn't touch other code other than trivially changing #ifdefs, I think my review should be enough.
Attachment #369229 - Flags: review?(mozilla) → review+
Keywords: checkin-needed
Version: unspecified → Trunk
Comment on attachment 369229 [details] [diff] [review]
add a new test plugin
[Checkin: Comment 3]


http://hg.mozilla.org/mozilla-central/rev/0da5126a17d3
Attachment #369229 - Attachment description: add a new test plugin → add a new test plugin [Checkin: Comment 3]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Peter, I think we should take this also for 1.9.1, though the old plugin tester won't be removed there. But since the old tools tester dirs are declared to be unmaintained, we'd stay otherwise the only consumers for the old tests.
Ah, I forgot, on 1.9.1 branch there is still a generic new test plugin. It builds out of the box, requires only the Makefile changes to point to it.
Attachment #374332 - Flags: review?(mozilla) → review+
(In reply to comment #6)
> Created an attachment (id=374332) [details]
> build the common test plugin on OS/2 also on branch
Ups, lost from the radar
Keywords: checkin-needed
Whiteboard: mozilla1.9.1 attachment 374332
Comment on attachment 374332 [details] [diff] [review]
build the common test plugin on OS/2 also on branch
[Checkin: Comment 8]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5cd96b6afea3
Attachment #374332 - Attachment description: build the common test plugin on OS/2 also on branch → build the common test plugin on OS/2 also on branch [Checkin: Comment 8]
Whiteboard: mozilla1.9.1 attachment 374332 → [fixed1.9.1rc1]
Whiteboard: [fixed1.9.1rc1] → [fixed1.9.1b99]
You need to log in before you can comment on or make changes to this bug.