"Sort by Name" in Library sorts descending (z-a) instead of ascending (a-z)

RESOLVED DUPLICATE of bug 443745

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 443745
10 years ago
10 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090322 Shiretoko/3.5b4pre ID:20090322030800

Running the following steps the sorting order of bookmarks, folders and special containers should be ascending. Instead all items are sorted descending. Surprisingly this is WFM with an older profile. But new profiles always show this issue.

Steps:
1. Create a fresh profile
2. Open Library and goto Bookmarks Menu
3. Select "Sort by Name" from within the toolbar

With step 3 all items in this folder are sorted descending instead of ascending. The same also happens with a fresh profile and Firefox 3.0.7.
Summary: "Sort by Name" in Library sorts descending instead of ascending → "Sort by Name" in Library sorts descending (z-a) instead of ascending (a-z)
Drew, already worked on sorting in the Library and could have some idea, iirc we also have a full test covering sorting in the Library
Awesome catch, Henrik. The litmus test case that'll be updated for this bug is https://litmus.mozilla.org/show_test.cgi?id=6394 .
Flags: in-litmus?
(In reply to comment #2)
> Awesome catch, Henrik. The litmus test case that'll be updated for this bug is
> https://litmus.mozilla.org/show_test.cgi?id=6394 .
We should be able to automate this...there's not need to waste people time on it.
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-litmus-
I can't reproduce on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090325 Shiretoko/3.5b4pre.  The problem does exist on 3.0, and the patch at bug 444179 (should have) fixed it.  (Bug 443745 was actually the relevant bug, but it was fixed by the aforementioned patch.)
Shawn, the issue resides on the user side. Due to this, it's going to stay
there on litmus, so this might be one of those exceptions where an update to
the litmus test case (as something along the lines for the tester to watch when
they're doing this test case) and an automated test case is worthwhile.
(In reply to comment #5)
> Shawn, the issue resides on the user side. Due to this, it's going to stay
> there on litmus, so this might be one of those exceptions where an update to
> the litmus test case (as something along the lines for the tester to watch when
> they're doing this test case) and an automated test case is worthwhile.
But we can create automated tests for the user side too, so I still don't see how it's worthwhile for a human to spend time testing it when a machine can do the job just as well (and even faster).
btw we already have automated test for sorting... if this doesn't work the test needs to be fixed.
So am I the only one this worksforme?
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090325 Shiretoko/3.5b4pre
Strange, this works for me on old crusty profiles as well as a new one using: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090325 Shiretoko/3.5b4pre

The sorted list of items in the Bookmarks Menu has the following in that order:

Get Bookmark Add-ons
Mozilla Firefox
Recent Tags
Recently Bookmarked
Yes, it's a dupe of bug 443745. The patch went into the branch after b3 was tagged. Sorry for the misleading build id. It should really be Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite?
Flags: in-litmus-
Resolution: --- → DUPLICATE
Duplicate of bug: 443745
So we should probably remove the existing Litmus test. It's not necessary anymore.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.