request: preferences to disable JavaScript snooping mouse position and keypress

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: kwiniec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7

Please add JavaScript preferences "Allow scripts to:" -- "Detect unclicked mouse cursor position", and "Detect alphanumeric key presses".

Only in the past few years has it become popular for Web pages to use JavaScript to determine the viewer's mouse cursor position (before they click) and their keypresses (before they hit return), and then use the information for invasive purposes (such as pop up subwindow-like content or send the information elsewhere across the Internet).  While at the same time, other page functions are so JavaScript-dependent that turning it off completely renders the page nonfunctional.  This new behavior is considerably more invasive than some of the currently implemented preferences such as "Change status bar text", and no 3rd-party solution has yet appeared to address it.

Reproducible: Always

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 1

5 years ago
Do not mark an enhancment request "resolved incomplete" without either resolving it or describing how it is incomplete.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 2

5 years ago
I marked this bug incomplete because it won't ever be exposed in the UI, and there isn't a point in tracking it unless someone creates a patch for it.  If after almost 5 years no one has taken this and found a patch, it seems likely that no one ever will.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

5 years ago
No evidence supporting the assertion that it "won't ever be exposed in the UI" was presented, and closure on unsupported assertion alone is improper.  Additionally, it is not a bug, it is an enhancement request, and there is no statute of limitations on requests.  Requests do not become less due to the passage of time alone.  There is no way to determine in advance the value of any particular enhancement request at any particular point in time without specific address.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 4

5 years ago
Then we're above my pay grade.  Gavin?
Flags: needinfo?(gavin.sharp)
I agree with Suzanne that this is not something we will be including in Firefox in the near term - this type of feature is best handled by add-ons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(gavin.sharp)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.