"Try Again" works only once on POST page that failed to load

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
10 years ago
8 years ago

People

(Reporter: david.balazic, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

When a page is to be loaded as a result on a POST and it fails, FF displays the error page with a "Try Again" button.

Clicking it pops up a dialog, if the POST data should be resent.

Steps:
 - click Cancel

Expected:
 - be able to click "Try Again" the second time and allowing the send in the dialog that ask for it

Actual:
 - the "Try Again" button is disabled, there is no way to reload the page (except for visiting the URL with no POST data, but that is different)

Reproducible: Didn't try
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

8 years ago
Tried with 3.6.12 on Windows XP Professional SP3.

The behavior is the same as described comment 0.

I used this URL to test:
http://www.cs.unc.edu/~jbs/resources/perl/perl-cgi/programs/form1-POST.html

I filled in some values, pulled out my LAN cable and clicked the submit button.
After a few seconds the error page appeared. I clicked Try again, then cancel.
Result: the Try again become disabled.

Full version string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2010-11-01]
Version: unspecified → 3.6 Branch

Comment 4

8 years ago
I see this behaviour on every fail-to-load-page with SM2.0 and SM2.1.
My steps to reproduce are:
- disable network connection
- try to load any page -> 'try again' window appears.
- hit 'try again', as loading fails again, the 'try again'-field is grey
- after reconnecting, only reload page works
You need to log in before you can comment on or make changes to this bug.