[Extension] Display issue on Mac

VERIFIED FIXED in BW-M3

Status

addons.mozilla.org Graveyard
Collector Extension
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: fligtar, Assigned: kinger)

Tracking

unspecified
BW-M3

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 369306 [details]
screenshot

See attached screenshot - the Search pane still thinks it's the first in the list.
(Assignee)

Updated

9 years ago
Assignee: nobody → brian
(Assignee)

Comment 1

9 years ago
I think this is caused by last-visible and first-visible attributes that are being set dynamically.
(Assignee)

Comment 2

9 years ago
Tentative fix checked in, revision 24004. Am going to let it bake a bit before closing this off.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

9 years ago
This fix works for me, however there is still a slight vertical line through a number of the tabs, visible in the screenshot here.
(Assignee)

Comment 4

9 years ago
Know anyone who worked on the Mac theme that I could ask about this?
(Reporter)

Comment 5

9 years ago
Alex, do you have any ideas on what's causing this issue, or know of a theme-savvy developer we could ask?
cc'ing some people
The vertical line should be fixed by bug 479156 - in what build are you seeing it?
(Assignee)

Comment 8

9 years ago
(In reply to comment #7)
> The vertical line should be fixed by bug 479156 - in what build are you seeing
> it?

Firefox 3.0.x and 3.1b3. Seems like it was fixed after. I will try on a more recent build.
(Assignee)

Comment 9

9 years ago
Created attachment 372576 [details]
No lines in Shiretoko

I've just tested in a Shiretoko (3.5b4) nightly, and the visual nuance is gone. Screenshot attached.
(Assignee)

Comment 10

9 years ago
(In reply to comment #9)
> I've just tested in a Shiretoko (3.5b4) nightly, and the visual nuance is gone.
> Screenshot attached.

Therefore, that wraps up this bug I think. FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

9 years ago
I think most of our users will be on Firefox 3, at least for a few months after Bandwagon's launch. I don't suppose there's a workaround or a way for the extension to fix this in Firefox 3?
From looking at the code I don't understand how this bug can affect Firefox 3 - are you sure it's visible there? The first/last-visible attributes weren't used there. Instead, the border radius was set on the containing ".radiogroupWrapper".
(Reporter)

Comment 13

9 years ago
Oops, you're right. This isn't a problem in Fx 3. For some reason I thought I had taken the screenshot in 3.

So this should all be good for launch.
Verified FIXED with the latest add-on Justin sent me, using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b5pre) Gecko/20090515 Shiretoko/3.5b5pre
Status: RESOLVED → VERIFIED
(Reporter)

Updated

8 years ago
Component: Collections → Collector Extension
QA Contact: collections → collector-extension
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.