[Extension] Can't create auto-publisher

VERIFIED FIXED in BW-M5

Status

P1
normal
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: fligtar, Assigned: mackers)

Tracking

unspecified
BW-M5
Dependency tree / graph

Details

(Reporter)

Description

10 years ago
I'm only filing this because I think I read that it was implemented, but maybe it's not. When I try to create an auto-publisher collection, it shows the activity indicator like it's working, but the collection is never actually made. It doesn't show up on the site, etc.

Updated

10 years ago
Assignee: nobody → dave
(Assignee)

Comment 1

10 years ago
I think this is the same regression that caused bug 485209.

It should be fixed as of revision 23968.

If you continue to see this problem please post any error console messages (with extensions.bandwagon.debug = true).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

10 years ago
Still happening for me. Relevant log messages:

bandwagon(5): Bandwagon.RPC.Net.send: 687167764501696: sending XMLHttpRequest  with data "name=fligtar's%20auto-publisher&description=fligtar's%20auto-publisher&nickname=fligtar_s_auto_publisher&listed=1"

bandwagon(5): Bandwagon.RPC.Net.send.onreadystatechange: 687167764501696: completed, response text = '<?xml version="1.0" encoding="utf-8" ?>
<error xmlns="http://addons.mozilla.org/" reason="invalid_parameters" details="" />
 
btw, can we have auto-publishers not have a nickname by default, and change the default description to "An automatically generated list of my installed add-ons"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I can create one, but it contains no add-ons. The entry in the Subscriptions panel is there, but with no items. When I try to open the collection on the web, I get 'Collection not found'.

From time to time I see this error, just FYI as I doubt it is related:

Error: now is not defined
Source File: file:///Users/brian/Library/Application%20Support/Firefox/Profiles/h22zvx34.default/extensions/sharing@addons.mozilla.org/components/bandwagon-service.js
Line: 437
(In reply to comment #3)
> From time to time I see this error, just FYI as I doubt it is related:
> 
> Error: now is not defined
> Source File:
> file:///Users/brian/Library/Application%20Support/Firefox/Profiles/h22zvx34.default/extensions/sharing@addons.mozilla.org/components/bandwagon-service.js
> Line: 437

Oh, that is bug 486001.
(In reply to comment #3)
> I can create one, but it contains no add-ons. The entry in the Subscriptions
> panel is there, but with no items. When I try to open the collection on the
> web, I get 'Collection not found'.

This is on Mac. When I load up the panel on Windows, I see the items in the list.

When I reload on Mac, the Retrieving spinner goes on endlessly and nothing is refreshed. Possibly related error:

bandwagon(1): Bandwagon.RPC.Service.onComplete: error notifying observer: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://bandwagon/content/ui/overlays/browserOverlayController.js :: anonymous :: line 203"  data: no]
(Assignee)

Comment 6

10 years ago
(In reply to comment #2)
> Still happening for me. Relevant log messages:
> 
> bandwagon(5): Bandwagon.RPC.Net.send: 687167764501696: sending XMLHttpRequest 
> with data
> "name=fligtar's%20auto-publisher&description=fligtar's%20auto-publisher&nickname=fligtar_s_auto_publisher&listed=1"
> 
> bandwagon(5): Bandwagon.RPC.Net.send.onreadystatechange: 687167764501696:
> completed, response text = '<?xml version="1.0" encoding="utf-8" ?>
> <error xmlns="http://addons.mozilla.org/" reason="invalid_parameters"
> details="" />

How odd. This API chokes when a apostrophe (') is present in the name.

The error occurs if I submit it as ' or (unnecessarily) encoded as %27.

Is this intentional, or an API bug?

> btw, can we have auto-publishers not have a nickname by default, and change the
> default description to "An automatically generated list of my installed
> add-ons"

Done. Revision 23992.
(Assignee)

Comment 7

10 years ago
(In reply to comment #3)
> I can create one, but it contains no add-ons. The entry in the Subscriptions
> panel is there, but with no items. When I try to open the collection on the
> web, I get 'Collection not found'.

Both these symptoms stem from the fact that the auto-publisher doesn't seem to be created instantly on the server.

After creating the autopub, the extension tries to publish the user's extensions. However, seeing as the autopub doesn't exist on the server yet, this fails. In this case, the extensions are published on the next startup.

We could mitigate against this if the "Create a new collection" API call returned the collection object. It is documented as doing so, but actually returns an empty document.
(Assignee)

Comment 8

10 years ago
(In reply to comment #5)
> When I reload on Mac, the Retrieving spinner goes on endlessly and nothing is
> refreshed. Possibly related error:
> 
> bandwagon(1): Bandwagon.RPC.Service.onComplete: error notifying observer:
> [Exception... "Component returned failure code: 0x80570016
> (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult:
> "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame ::
> chrome://bandwagon/content/ui/overlays/browserOverlayController.js :: anonymous
> :: line 203"  data: no]

Not sure it's related, but I'm surprised you haven't seen this error (outside of auto-publishing) as it's to do with the alertsService.

I can't reproduce, but I've checked in a blind fix (read: try...catch) in the above case.
I can look into the apostrophe issue and the empty document issue.  But, if / when you run into sharing API issues, could you file dependent bugs assigned to me so I can track what's wrong and try to get them into my work queue?
Depends on: 486125
Depends on: 486126
(Reporter)

Comment 10

10 years ago
Okay, creating an auto-publisher works for me now. However, it doesn't have any of my add-ons in it.
(Reporter)

Updated

10 years ago
Priority: -- → P1
(Reporter)

Comment 11

10 years ago
Moving to revised M5 milestone (4/28).
Target Milestone: BW-M3 → BW-M5
(Assignee)

Comment 12

10 years ago
(In reply to comment #10)
> Okay, creating an auto-publisher works for me now. However, it doesn't have any
> of my add-ons in it.

This should be working now. As soon as the auto-pub is created, it is subscribed to and fill with the user's add-ons.

r24545
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED
(Reporter)

Updated

9 years ago
Component: Collections → Collector Extension
QA Contact: collections → collector-extension
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.