Closed Bug 485361 Opened 11 years ago Closed 7 years ago

Invalidation bug

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jwatt, Unassigned)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

Here's an SVG file that does not invalidate correctly when the content is moved. It's an Inkscape generated file that needs to be reduced to a simple testcase.
This works fine in Firefox 3.1 beta 3, but it's broken on trunk.
BTW: This is also broken in a SeaMonkey comm-central/1.9.1 build from yesterday, so this is also a 1.9.1 branch issue.
works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008072203 Minefield/3.1a1pre ID:2008072203
fails:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008072303 Minefield/3.1a1pre ID:2008072303

=> range:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-07-22+03%3A00%3A00&enddate=2008-07-23+03%3A00%3A00

=> caused by bug 445297? CCing Roc.
Version: unspecified → Trunk
Could be that bug, yeah. But I'm a bit confused, comment #1 seems to contract the range in comment #3.
Jonathan, you're really sure about that testcased working in Fx 3.1 beta 3?
Weird. Yeah, it works fine for me with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
well the testcase is still failing for me with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090418 Shiretoko/3.5b4pre ID:20090418045023

-> maybe a windows only issue?
ok, this is fixed now.

fails:
http://hg.mozilla.org/mozilla-central/rev/7e9d9227f498
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090424 Minefield/3.6a1pre ID:20090424041640
works:
http://hg.mozilla.org/mozilla-central/rev/dfff608ebad0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090425 Minefield/3.6a1pre ID:20090425043745

range:
=> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7e9d9227f498&tochange=dfff608ebad0

fixed by Bug 463939 i presume.
Yeah, it could be more hidden than fixed though. :( Not sure.
So, I've been looking at simplifying the testcase to create a minimalistic reftest - what exactly is causing the invalidation issue here? Is it the call to 'matrix'? What's the focus of the invalidation issue?
The matrix shrinks the rocket and moves it (to somewhere off the screen I think). Without the wallpaper patch in bug 463939 the rocket is not cleared from its original position. You would need to locally back out the patch for bug 463939 or test with a 3.5 branch build to see the effect.
Note that bug 738192 fixed the performance hit that bug 463939 introduced.

This bug was fixed by bug 463939 some time ago and with bug 738192 landing we no longer need to track this bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.