Flash direct mode - reload doesn't work properly with this content

RESOLVED WORKSFORME

Status

()

Core
Layout
P2
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: nick, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---
Bug Flags:
blocking1.9.2 -
wanted1.9.2 -
blocking1.9.1 -
wanted1.9.1 +
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed in an future Flash version], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30618)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)

This URL has some flash content which has been published with the wmode=direct and hardware acceleration= direct (CS4 new option). Flash player targetted is still 9. 

When the reload button is clicked it doesn't refresh properly - the content isn't displayed until you either resize the window or activate a menu when the content can be seen again. This only happens with direct mode - window or GPU seems to work better. All other browsers have no problem with this.

This is the symptom in Vista, in XP this doesn't seem to happen, the sympton there is that when full screen mode is exited (again use the URL provided as that has a full screen button) the player freezes. Again it is the direct mode that seems to cause this. 

Can you please get this fixed as direct mode is very useful for smoothing play back of animation and will be used a lot, but not with bugs like this. Also, every other browser is fine with this apart from Firefox.

Best wishes, 

Nick

Reproducible: Always

Steps to Reproduce:
1.Play content of http://www.idealhome.tv/securearea/automate/ask540/tour2k.html
2.Press reload
3.On vista see reload doesn't work properly, on XP full screen mode exit freezes playback
Actual Results:  
Either content not displayed (Vista) or frozen  player (XP)

Expected Results:  
played the content! Firefox beta 3.1 behaves a bit better but the problems are still there

Please fix in 3.1!
Confirmed with latest trunk on Windows Vista. I haven't tried XP yet.
Regression range is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2007-08-02+09%3A00&maxdate=2007-08-02+12%3A00
Seems to be caused by Bug 381512.
Blocks: 381512
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Flags: blocking1.9.2?
Flags: blocking1.9.1?
Keywords: regression
Ria, please cc me on bugs that are regressions from my changes?  I usually don't get dep-change bugmails.

jst, do we have any contacts at Adobe who might be able to tell us what's going wrong here on their end?  I can't reproduce this (on Mac), but of course their plug-in could just be doing something differently....  and I think I have Flash 10 here in any case.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9.0.10?
That is, how the sequence of calls from us differs from the sequence they expect.  The main effect of bug 381512 was to SetWindow() before starting to pump data into the plug-in, which is what we used to do in Firefox 2 as well...
(Reporter)

Comment 4

9 years ago
Hi Guys, any news on this? if you need extra data or testing just please shout. Deperate to get a fix into your next release ...

regards,

Nick
Can't really "block" our security updates on this, but if you get a trunk/1.9.1 fix we can approve the patch later.
Flags: blocking1.9.0.10? → wanted1.9.0.x+
(Reporter)

Comment 6

9 years ago
How do I get a trunk/1.9.1 fix please?
Cc:ing some Flash player folks who might be able to help here.
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P2
(Reporter)

Comment 8

9 years ago
If I can lobby for some action here ... the direct mode available through hardware acceleration settings in CS4 and wmode in HTML is a fantastic move forward in performance and smoothness of animation.

We're getting results on the fly in the browser which are as smooth as rendered video and Firefox is the browser where we get our smoothest results.  So these settings are going to be popular and its very important that Firefox fixes these reload issues or content providers will shy away from firefox. As I say, the reload issue does not happen in other browsers. Thanks in anticipation of your active support. Nick

Comment 9

9 years ago
Well the idea of Flash using GPU via direct is something new only to Flash Player 10.  If this is happening with Flash Player 9 then its likely not a player bug.  I did test this with 10.0.22.87 on my Mac using FF 3.0.7 and I do not have this problem
(Reporter)

Comment 10

9 years ago
That's not correct. Direct mode isn't just applicable to Flash 10. You are allowed to publish swf's to 9 and 10 that use either GPU or direct mode hardware acceleration. This can be seen through the CS4 publish settings options where hardware acceleration is available to 9 and 10 files but not earlier.

I agree that this bug doesn't happen on mac's - it doesn't occur on XP either, it is a vista issue.

Comment 11

9 years ago
I think you just clarified that you are publishing for Flash Player 9 not testing on it.  I was speaking specifically to the Flash Player and this I misunderstood.  So you have this published for FP9 but see this but when testing what build of Flash Player?
Flags: blocking1.9.2?
(Reporter)

Comment 12

9 years ago
Hi Guys, 

Yes I'm publishing to Flash player 9 with direct mode enabled and on playing via Flash Player 10, this problem occurs. 

However, when i play with Flash player 9 (9,0,28,0) this problem doesn't appear. 

So it seems to be a Firefox, Vista, Direct mode, Flash Player 10 combination.
regards,
Nick
I think we still need someone from Adobe to answer Boris' question in comment #3.
Given that:
 (1) we shipped this in 1.9.0.* / Firefox 3.0.*
 (2) we're still waiting on answers to the questions in comment 3
I don't think we can really block 1.9.1 on this, so moving from the blocking list to the wanted list.
Flags: wanted1.9.1+
Flags: blocking1.9.1-
Flags: blocking1.9.1+
Flags: blocking1.9.2?
(Reporter)

Comment 15

9 years ago
Hi Guys, We're still desperate for a fix on this (a whole project is reliant on it), I'd don't want to create anymore hassle but is there anyway of speeding a fix up?

Many thanks

Nick
(Reporter)

Comment 16

9 years ago
Can I still confirm that this is being worked on please. It's missed 3.5, any idea which release its scheduled for?
Best wishes
Nick
(Reporter)

Comment 17

9 years ago
I have also logged this bug on the Adobe Flash Player bug management system in the hope to attract some attention from Adobe engineers to it. Please see

https://bugs.adobe.com/jira/browse/FP-2322

An update as to when this will be fixed would be most appreciated. 

Thanks

Nick
Flags: wanted1.9.2-
Flags: blocking1.9.2?
Flags: blocking1.9.2-

Comment 18

9 years ago
Sorry guys I should have posted this a while back.  I have reproduced this and logged a bug internally.  I can't provide date related information but it will be looked for a future release.  Thanks for all the valuable information to help me out.

~Charles
Thanks for the update Charles! Please let us know when this bug gets fixed in a shipping (beta is fine) version.
Whiteboard: [fixed in an future Flash version]
(Reporter)

Comment 20

9 years ago
Excellent news - will this be a Flash fix or a Firefox fix?

Comment 21

9 years ago
Its slated to be fixed in Flash unless our engineers find something unexpected.  I'll update the bug here once we have a fix that is released.  Bug ID= 2339606
(Reporter)

Comment 22

8 years ago
Hi Charles, 

A fix is desperately needed for this - we can't use the brilliant direct mode feature simply because Firefox has this issue. 

Can you please provide an update as to when a fix will be available?

Many thanks

Nick

Comment 23

8 years ago
Hi Nick,

We should have this fixed in Flash Player 10.1 beta.  Download here:
http://labs.adobe.com/downloads/flashplayer10.html
(Reporter)

Comment 24

8 years ago
Thanks Charles, I can confirm that it is indeed fixed on Vista / Firefox / Flash 10.1 beta / direct mode. Well Done!

I will be giving it some real thrashing now and will report any issues I find back here. 

Thanks again - I'd almost given up on this forum but you have restored by faith!

All the best, 

Nick
Sounds like this was an issue on the Flash end.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 26

8 years ago
Glad I could help.
You need to log in before you can comment on or make changes to this bug.