Closed Bug 485448 Opened 11 years ago Closed 10 years ago

Allow to mark tasks complete in calendar view with one click

Categories

(Calendar :: Tasks, enhancement)

x86
Windows Vista
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 340025

People

(Reporter: avatar, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

Currently in order to mark a task complete through the calendar view, I have to double-click it, click on status drop-down, click "Completed on", then click "Save and Close". That's 5 clicks. I'd appreciate if I could do it with one, like I already can using the task list.

The task label in the calendar view has a small icon on the left showing its status. It would be ideal, if clicking this icon would toggle the status of the task.

Marking tasks complete would also be made easier by 485447.

Reproducible: Always
I could imagine some sort of checkbox in the task box in the calendar view. Setting uiwanted.

Alternatively, we could add a context menu entry for common task operations. This would be 2-3 clicks, but I think thats still better than 5!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
I'd request to not clutter the view anymore, e.g. by adding a checkbox to the task box. See existing discussion on similar topic in Bug 391838 about using the icon itself to toggle the status.

Using a context menu similar to the task list is a better solution as already suggested in Bug 391838 by Christian. For that solution see Bug 340025 too.
Lets take care of this in bug:
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340025
You need to log in before you can comment on or make changes to this bug.