Status

SeaMonkey
General
P3
normal
RESOLVED DUPLICATE of bug 227321
18 years ago
13 years ago

People

(Reporter: Warren Harris, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Subject: 
            Re: URN syntax
       Date: 
            Thu, 10 Aug 2000 22:10:08 -0700
      From: 
            hyatt@netscape.com (David Hyatt)
        To: 
            Warren Harris <warren@netscape.com>
        CC: 
            Ray Whitmer <rayw@netscape.com>, Chris Waterson 
<waterson@netscape.com>
 References: 
            1




This is easy to fix... give me a bug on it...

Warren Harris wrote:
> Dave,
> 
> I've noticed that the urns we use in in manifest.rdf files have the 
> form "urn:mozilla:package:...". Ray tells me that urns should look 
> like this: "urn:inet:mozilla.org:package:...". I'm not sure how 
> important this might be long-term.
> 
> Warren
>
(Reporter)

Comment 1

18 years ago
Marking nsbeta3. Probably important to get this right since we're trying to 
standardize all this chrome/xul stuff.
Keywords: nsbeta3

Comment 2

18 years ago
nsbeta3-, ->future
Status: NEW → ASSIGNED
Whiteboard: [nsbeta3-]
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
I don't think this can be futured. It's like shipping a product that only parses 
broken html, and then telling everybody "just do it the broken way." Erasing 
nsbeta3-.
Whiteboard: [nsbeta3-]

Comment 4

18 years ago
This bug is trivial compared to the 70 or so other bugs we have already
committed to fix, but are probably not going to be able to fix. If we started
plussing bugs like this, we'd have 700.  We are date-driven, and with only 3.5
weeks left we have to cut to fit.  This one does not fit, it will require far
too many changes to the RDF, for zero benefit to the product. These are just
internal identifiers, they don't need to be standardized now. Hyatt now wishes
he called them Purple Fuzzy Bunnies (PFBs), but if you like you can think of
them as Unidentified Resource Notation.
nsbeta3-, cc jrgm
Whiteboard: [nsbeta3-]

Comment 5

17 years ago
FWIW:  Eventually, there will (probably) be a standard for URN's.  There isn't
one now.  I doubt urn:mozilla will be legal or registerable, but I do not know.
 I suspect urn:inet:... will be legal, but I do not know that either.  Without a
real standard list it is hard to say what is really legal and illegal, as long
as no illegal constructs or characters appear.  We are not the only ones making
up our own names, without any registered scheme that allows us to do so.  I
don't like it, I would never advocate this type of urn's, but I cannot strongly
condemn it yet.  Using URNs for strings to identify things is just guessing
right now, the way I read the documents.  If we were to use reserved characters
that the current specs forbid, then I could strongly condemn it (which was one
reason we finally chose not to use them for contractid's).
Product: Browser → Seamonkey

Comment 6

13 years ago
FWIK, the inet scheme has never been official, and there seem to be ne plan to
register it... This bug should be resolved WONTFIX.

See also bug 227321.

Comment 7

13 years ago
Although it is common practice to duplicte newer bugs to older bugs, the never
bug seems clearer and doesn't contain confusing comments.

*** This bug has been marked as a duplicate of 227321 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: [nsbeta3-]
You need to log in before you can comment on or make changes to this bug.