Seamonkey not recognized as a browser by turbotax.com

VERIFIED INVALID

Status

SeaMonkey
General
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Ken Kellaher, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.21) Gecko/20090303 SeaMonkey/1.1.15
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.21) Gecko/20090303 SeaMonkey/1.1.15

Many sites like Turbotax do not recognize Seamonkey as a browser.  This needs to change immediately.  They recognize Firefox, so they should see Seamonkey.  You should change the build identifier to include firefox or work with these sites get Seamonkey on the list.  I am not going to use Firefox, its just a IE clone and I Hate IE.

Reproducible: Always

Steps to Reproduce:
1.go to the site and try to start a tax return using seamonkey
2.
3.
Actual Results:  
the site stated to download firefox or IE

Expected Results:  
Should have started doing my return

This has been an issue for a long time and I am surprised you haven't fixed it yet.
There is nothing to fix because this is an error in the webpage itself.
Send a mail to the owner of such broken webpages and point them to http://www.geckoisgecko.info/

You can create bug reports in the Tech Evangelism Product for each page if not already filed and help to write letters to owners of such domains.
see bug 334967 for the tracking bug
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Thats not really a solution.  Its just laziness in programming.    You as a group should be making sure that gets out to all sites like that.  Its a bug because when this was Mozilla there really was no problem.  Firefox screwed the whole thing up.  The wording in Firefox should be changed to match Seamonkey.  Since Seamonkey is the original and only good browser.
>Its just laziness in programming.
yes, from the website owner with his broken browser sniffing.

Not Firefox screwed it up, the stupid webmasters did and we don't follow the very old IE rtyle to make everything work and break the whole web.

Updated

9 years ago
Status: RESOLVED → VERIFIED
Version: unspecified → SeaMonkey 1.1 Branch

Comment 4

9 years ago
fwiw, Minefield isn't either....
Summary: Seamonkey not recognized as a browser → Seamonkey not recognized as a browser by turbotax.com
You need to log in before you can comment on or make changes to this bug.