Icecast Stream crashes Firefox

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Jan Gerber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090325 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090325 Minefield/3.6a1pre

playing the live video stream from Mozilla Add-Ons Workshop - Berlin on
http://air.mozilla.com/europe/
Firefox keeps crashing, here a traceback

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f6ae37ff950 (LWP 5568)]
0x00007f6aff957069 in nsAudioStream::Write ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
Current language:  auto; currently asm
(gdb) bt
#0  0x00007f6aff957069 in nsAudioStream::Write ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
#1  0x00007f6aff9590db in nsOggDecodeStateMachine::PlayFrame ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
#2  0x00007f6aff9597fe in nsOggDecodeStateMachine::Run ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
#3  0x00007f6affcf7152 in nsThread::ProcessNextEvent ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
#4  0x00007f6affccc65a in NS_ProcessNextEvent_P ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
#5  0x00007f6affcf77b6 in nsThread::ThreadFunc ()
   from /home/j/src/mozilla-central/dist/bin/libxul.so
#6  0x00007f6afe5abec3 in _pt_root ()
   from /home/j/src/mozilla-central/dist/bin/libnspr4.so
#7  0x00007f6b005ac3ba in start_thread () from /lib/libpthread.so.0
#8  0x00007f6afad25fcd in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()
(gdb) 



Reproducible: Always

Comment 1

9 years ago
From the stack trace looks like it might be bug 485642.
(Reporter)

Comment 2

9 years ago
does not crash if i take media/libsydneyaudio/src/sydney_audio_alsa.c from libsydneyaudio svn it does not playback nicely though, problem could be slow internet connection, but it hangs shortly and than plays back to fast, just to hang again after some time...
(Reporter)

Comment 4

9 years ago
good question, will look for an icecast stream or set one up to test soon.
did not notice that crash recently though.

Comment 5

9 years ago
Sounds like WFM. (Also, likely fixed by the bug mentioned in comment 1).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.