Pictures displaced on Ebay image carousel

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
The pictures of the cars in the image carousel are sometimes displaced (on first load/shift reload?). This is in the "Additional Photos" section. The pictures of the cars should just be beneath the large picture of the car. Instead, they are a lot higher.

I first thought this was basically the same issue as bug 466586, because iirc, I think I saw the same regression range as that bug.
I had even a sort of smaller testcase that showed the issue, but I haven't saved that :(
Flags: blocking1.9.1?
Keywords: testcase-wanted
OS: Windows XP → All
Summary: Pictures displaced on Ebay image caroussel → Pictures displaced on Ebay image carousel
Probably need a testcase here to understand if the problem is something that's likely to affect other pages or something specific to this page (or even a bug in its script).  Hard to block on it without that.
Won't block until we have more data.
Flags: blocking1.9.1?
FWIW, this can also be seen with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7pre) Gecko/2009020404 GranParadiso/3.0.7pre ID:2009020404

Would be nice to have the regression range too.
Keywords: regressionwindow-wanted
sorry, cannot repro the issue. a (reduced) testcase and/or screenshot showing the issue would be cool.
Created attachment 371064 [details]
screenshot

(In reply to comment #4)
> sorry, cannot repro the issue. a (reduced) testcase and/or screenshot showing
> the issue would be cool.

Sure. Here the screenshot.
BTW, this works as late as Firefox 3.1 beta 3 on Windows Vista.
Sander: any chance you could help us out here with a minimized testcase?

Comment 8

9 years ago
Created attachment 372233 [details]
testcase

This appears to just be a case of bad UA sniffing (script applied when Gecko is in the UA but Firefox isn't) with a script which fails to account for the big image not yet being fully loaded (shift-reload consistently shows the bad positioning; a regular reload doesn't). 
SeaMonkey 1.1.x (Gecko 1.8.1) shows the same bad positioning, so I don't think this is a regression.

Attaching a semi-reduced testcase which shows more or less what the script is doing.

This should either be invalid, or tech evangelism.

Updated

9 years ago
Keywords: regression, regressionwindow-wanted, testcase-wanted → testcase
Sander: thanks for much for doing this; I should've checked before asking Martijn to file, that adding "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.8) Gecko/2009032609 Firefox/3.07" to the new, user-defined pref general.useragent.override via about:config would "fix" the issue.

I'm happy with either INVALID or tech evang.
Marking as invalid.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
I don't think that it will be worth for Ebay to update their UA detection for development versions of Firefox. I think invalid is fine. Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.