Javascript window.open() function loads nothing in window

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: John Hayward-Warburton, Assigned: jst)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
On the above page, about half way down, is the phrase "The poster announcing
this open day is here." 'here' is a link with an associated script to open a new
window for the page, but though the page is requested by the browser, it fails
to display.
(Reporter)

Comment 1

17 years ago
Problem partially solved: when the href associated with the new page is set to
'#' (but window.open() still given the proper page name), the new window DOES
open with the correct page.
The testcase page has been changed because of this. However, the original case
that didn't work with Mozilla but was fine with Netscape 4.74 and MSIE was a bit
worrying. (john@billabong-media.com)

The form of the failed call was <a href="/blah.html" target="_popup"
onClick="window.open('/blah.html', '_popup',
'width=446,height=319,menubar=0,resizable=0,scrollbars=0); return 1;">TEXT</a>

It works with the href='#' and the target=.. removed.
(Reporter)

Comment 2

17 years ago
Sorry, me again. Regular failure case:
http://silversurfers.uk.com/tikka/index2.shtml

Click on the "(C) Silver Surfers MM" text in the bottom right of this page. A
new window opens but nothing appears. After three or four MIDDLE clicks of the
mouse, it does appear.

Comment 3

17 years ago
Browser, not engine. --> DOM Level 0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale
(Assignee)

Comment 4

17 years ago
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future
First case WORKSFORME 20000819 WinNT4. Second one tries to load itself in the 
first one's popup! But nothing loads, although the title is there.

If I restart Moz, the second case works as well. <shrug>

Gerv

Comment 6

17 years ago
Both test cases work for me on Linux build 2000091908.

Comment 7

17 years ago
Setting bug status to New.  Bugs whaich have been triaged to a target milestone
should not be Unconfirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 8

17 years ago
Seems to work on Linux nightly build 2000100308.
(Assignee)

Comment 9

17 years ago
Worksforme, Win2k, mozilla build from last-week-or-so.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.