configure.in: Don't assume darwin is Cocoa

RESOLVED DUPLICATE of bug 486782

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 486782
9 years ago
9 years ago

People

(Reporter: Jeremy Huddleston, Assigned: Jeremy Huddleston)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: xulrunner-1.9.0.7 Darwin X11

The configure script makes an assumption that when the CHOST is darwin, the build is using Cocoa.  This doesn't work when we're building for X11 on darwin.  We use the following patch to build xulrunner for X11 on Darwin in MacPorts:

--- configure.orig	2009-03-19 21:02:35.000000000 -0700
+++ configure	2009-03-19 21:03:53.000000000 -0700
@@ -5807,11 +5807,10 @@ case "$host" in
     ;;
 
 *-darwin*)
-    HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX -DXP_MACOSX -DNO_X11"
-    HOST_NSPR_MDCPUCFG='\"md/_darwin.cfg\"'
+    HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX -DXP_MACOSX"
+    HOST_CXXFLAGS="$HOST_CXXFLAGS -DXP_UNIX -DXP_MACOSX"
     HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O3}"
     MOZ_FIX_LINK_PATHS='-Wl,-executable_path,$(LIBXUL_DIST)/bin'
-    LIBXUL_LIBS='$(XPCOM_FROZEN_LDOPTS) $(LIBXUL_DIST)/bin/XUL -lobjc'
     ;;
 
 *-linux*|*-kfreebsd*-gnu)


---

The -DNO_X11 and LIBXUL_LIBS should be added only if the toolkit is cocoa or mac.

Reproducible: Always
(Assignee)

Updated

9 years ago
Depends on: 486782
(Assignee)

Updated

9 years ago
No longer depends on: 486782
(Assignee)

Updated

9 years ago
Depends on: 486782
(Assignee)

Updated

9 years ago
Assignee: nobody → jeremyhu
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

9 years ago
This is fixed in the patch for bug #486782
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486782
You need to log in before you can comment on or make changes to this bug.