TM: Google Maps Api - problems displaying maps in Playground - Minefeld 3.6.a1 29.3.2009

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: bernhard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090329 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090329 Minefield/3.6a1pre

problems displaying maps of those URLS
http://code.google.com/apis/ajax/playground/?exp=maps#map_simple
http://code.google.com/apis/ajax/playground/?exp=maps#map_markers
http://code.google.com/apis/ajax/playground/?exp=maps#map_animate
http://code.google.com/apis/ajax/playground/?exp=maps#map_info_window
http://code.google.com/apis/ajax/playground/?exp=maps#map_event_simple

This sometimes works 
http://code.google.com/apis/ajax/playground/?exp=maps#map_event_context


Reproducible: Always

Steps to Reproduce:
1.run these URLs

Actual Results:  
Displaying maps of upper mentioned URLS does not work any more

Expected Results:  
displaying maps

3.1.Beta 3 had a problem with displaying Google Maps Api with type  G_PHYSICAL_MAP,  worked with Type G_HYBRID_MAP

Now in Minefeld 3.6.a1 29.3.2009 my maps do work in normal street mode,
but there are NOW problems on Google Maps playground.
It all works with 3.0.8.
Does it work if you run Firefox in the Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode

If not, does it work if you disable javascript.options.jit.content to false and restart Firefox ?
(Don't forget to enable it again later)
(Reporter)

Comment 2

10 years ago
Result with Minefield 3.6.a1 29.3.2009
With Tools / options /Content / Enable Javascript = False 
all contents of the playground are empty, not only the map-part.

Cannot test 3.1.Beta 3 time being, as Minefield is installed.
(Reporter)

Comment 3

10 years ago
Reinstalled 3.1.Beta 3, 
now works both on my site and on Google Maps Playground
works for both types   G_PHYSICAL_MAP and G_HYBRID_MAP
did not change anything !  ?


Upgraded to Latest firefox-3.6a1pre.en-US.win32.installer.exe of 30.3. - 18:58 same problems with above mentioned URLS  as with built of yesterday:
problem: with Java disabled 3 empty windows,  
problem: with Java enabled  1 empty window.
i meant you should disable jit, enter about:config as url in Firefox URL Bar, confirm the warning, enter jit in the filter box at the top and set javascript.options.jit.content to false.
btw: Java is very, very different from Javascript (the similar name is some old marketing thing if I remember that correctly)
(Reporter)

Comment 5

10 years ago
sorry, only used about:config once before for Firefox clear history setting.

Yes, when disabling jit it works.
No, when running in safemode it does not work.
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Summary: Google Maps Api - problems displaying maps in Playground - Minefeld 3.6.a1 29.3.2009 → TM: Google Maps Api - problems displaying maps in Playground - Minefeld 3.6.a1 29.3.2009
(Reporter)

Comment 6

10 years ago
Now using the latest built: firefox-3.6a1pre.en-US.win32.installer.exe	01-Apr-2009 06:17   it works, problem seems to be solved.
marking wfm, please reopen if you get this again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

10 years ago
with firefox-3.6a1pre.en-US.win32.installer.exe	07-Apr-2009 11:31
Problem is back,

get empty bottom window running site
http://code.google.com/apis/ajax/playground/?exp=maps#map_simple
as well as on my pages.

repeatable and with program aborts this time. 

also disableing  jit, about:config - javascript.options.jit.content to false.
does not help this time
Severity: normal → critical
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
This is very likely not the same bug, since turning the JIT off does not help. You are probably seeing bug 487271. Suggest leaving this bug as WFM, or better, finding out the JIT-only fix that went in when it stopped biting.

/be
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
Bug 487271 is a crash bug, but I can see ways the underlying flaw would result in JS errors or even incorrect results, not crashes. In any case, reopening is the wrong step because you showed that the bug bites with JIT off.

If you still see the problem after the fix for bug 487271 goes in (today, should have been last night but I was waiting for code review), then please file a new bug with fresh details -- including any error console traffic. Thanks,

/be

Comment 11

10 years ago
In reply to comment #5)
> sorry, only used about:config once before for Firefox clear history setting.
> 
> Yes, when disabling jit it works.
> No, when running in safemode it does not work.

Since safemode disables the jit, I think you may have been confused about about:config. (Of course having safe mode disable the jit seems pretty silly, since people like the press and MS use it for perf testing and it also implies that what we're shipping isn't "safe", but that's bug 478846, I believe.)
(Reporter)

Comment 12

10 years ago
in reply to comment #10

Did You mean firefox-3.6a1pre.en-US.win32.installer.exe	08-Apr-2009 06:22,
what was not availble this morning or next night build ?
The build of 08-Apr-2009 06:22 still has the same problem.

/bk
(Reporter)

Comment 13

10 years ago
with build of 9th Apr-2009 working again, thanks 
/bk
You need to log in before you can comment on or make changes to this bug.