Visibility:Collapse Style doesn't render properly

RESOLVED DUPLICATE of bug 242997

Status

()

RESOLVED DUPLICATE of bug 242997
10 years ago
10 years ago

People

(Reporter: crazyone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

When using visibility:collapse on an entire column through the COL tag, we should be hiding the column completly, here what happens is that the data just shifts aside but the reserved space stays...

It's even more visible when you have tangible data in the table with different size columns. For example i have used a database output instead of a manual output and the second columns was way bigger than the third, if i hide it it gives the second portion example. You will definitely see what i mean by reserved space. Also the styles seem to follow, the borders of the visibility:collapsed cells should be also removed from the output...

Reproducible: Always

Steps to Reproduce:
1.Open example URL
2.Look at source of page
3.Copy example
4.Twiddle/fiddle with code to see if it aint me, but i don't think i'm that bad :)
Actual Results:  
The space for the column is reserved in the output and it doesn't draw the table properly having several styles not ouputted correctly.

Expected Results:  
The column space and table space should be calculated using style changes. The styles of a cell that is collapsed should not show, not only the content of it, but the whole cell.

The column should definitely disapear. PS, i found this problem while creating a framework for visual webcontrols for PHP. I wanted to hide the columns so they are not seen on the webpage but present. My next step was to create a JS model that could toggle into view those columns. So please make sure that the bug is also fixed when dynamically setting the option to visible and collapsed.

Thanks

PS: No workaround, but not high priority, so i'm putting it at normal severity

Comment 1

10 years ago
I think this is a dupe... can't find it though.
Component: General → Layout: Tables
OS: Windows Vista → All
Product: Firefox → Core
QA Contact: general → layout.tables
Hardware: x86 → All
(Reporter)

Comment 2

10 years ago
I searched the engine for similar bugs using visibility and collapse and found 1 other bug but it is not the same problem at all. I couldn't find anything that actually matched my problem with the two keywords so i opened one.

Comment 3

10 years ago
how about bug 242997
(Reporter)

Comment 4

10 years ago
Would look like it, but i bring another angle to it via the javascript which was not mentionned... Just don't overlook it if you close my bug...

Comment 5

10 years ago
the url in that bug uses javascript.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 242997
You need to log in before you can comment on or make changes to this bug.