SWFObject is working on all browsers but in FireFox 3.0.8, Menus are coming behind the flash area.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: FahadB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB5; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

Hi there

I am using the SWFObject to embed my flash and alternate flash
content, on all browsers the flash menu onMouseEvent successfully
overlaps the flash intro beneath it, but only on FireFox latest
version the flash is not considered as transparent and displaying the
flash intro on the top of the menus.

Is it something with the code or with the browser compatibility:

<script type="text/javascript" src="swfobject.js"></script>
<script type="text/javascript">
       swfobject.registerObject("Spotlight_en_gb", "8");
</script>

<div id="HighlightSectionHolder">

 <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
width="770" height="276" id="Spotlight_en_gb">
   <param name="movie" value="Main_en_gb.swf" />
   <param name="wmode" value="transparent" />
   <param name="menu" value="false" />
   <!--[if !IE]>-->
   <object type="application/x-shockwave-flash" data="Main_en_gb.swf"
width="770" height="276">
   <!--<![endif]-->
                <!-- This is the Alternate content .net control -->
                 <span class="topCorner"></span>
                 <%@ Register TagPrefix="uc1" TagName="TopHighlights"
Src="~/TopHighlights.ascx" %>
                 <uc1:TopHighlights id="TopHighlights1"
runat="server"></uc1:TopHighlights>
               <!--Non Flash Content End-->
               <!--[if !IE]>-->
   </object>
   <!--<![endif]-->
 </object>

</div>

Any help would be much appreciated,

Thanks
Fahad.

Reproducible: Always



Expected Results:  
The main flash spotlight area should be considered as transparent flash and the menu navigation which is in flash too should be overlapping the spotlight.
>on all browsers 
name the browsers, i think flash isn't supported in lynx as example and that means "all" is wrong.

>Any help would be much appreciated
We don't help here in bugzilla, this is the tracking tool for our developers. Please use the newsgroups or Forums if you need help

> <object classid> 
is not supported by Gecko.
>  <object type="application/x-shockwave-flash"> 
is used but there is no wmode paramter for it and without wmode the flash isn't set into the windowless mode and is always on top
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Thanks, the issue is sorted, the only issue was the object tag needs to have the wmode="transparent" in it.

Fahad
Resolution: INVALID → FIXED
fixed would be mean that this would be a bug and a patch would be attached to this bug.
marking invalid again, the classid is an ActiveX classid and not supported and the wmode param was missing -> invalid
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.