Change case of selected characters by keypress or menu item

RESOLVED FIXED in Future

Status

Skywriter
Editor
P4
enhancement
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Marco Warga, Assigned: Sean Burke)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

763 bytes, application/octet-stream
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: 

Changing the case of all currently selected characters to upper or lower case by pressing a key combination or chosing a menu option.

MS Visual Studio 97-2008: Press LCTRL+LSHIFT+U or LCTRL+LSHIFT+L resp.
Notepad2 (http://www.flos-freeware.ch): same as above
Textpad (http://www.textpad.com): use menu option


Reproducible: Always
Definitely a feature that I would want. Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Whiteboard: editor
(Assignee)

Comment 2

9 years ago
I have started to play around with this and hopefully should have something working shortly. I am currently having issues getting any new clone to work do to a bootstrap.py issue so this may back me up a bit.

Plan:
1.) Get the base code working so that the enhancement is working correctly
2.) Add undo/redo support
3.) If/When block selection is added, code in support for it.
Summary: Change selected characters case by keypress or menu → Change case of selected characters by keypress or menu item
(Assignee)

Comment 3

9 years ago
Created attachment 370458 [details]
Bundle for changes

Bundle for changes, so far has passed the tests I have given it however since this is my first shot messing with undo/redo in actions there may be some unexpected behavior.

Comment 4

9 years ago
Hi Sean,

I pushed this in changeset #dc1c9d1373a5.

What I would like to see:

- This works in simple cases (highlight a word) but I get bugs when I do things like go across lines. Then the newline seems to get swallowed and the lines join. Do you see that behaviour?

- It would be nice to have commands that map to this: either "uc" and "lc" or "toupper" and "tolower" (could use "alias: 'uc'" to uc/lc). In the commands you could then have 'withKey: "CTRL SHIFT u"' and move that out of the bindlistener section.

Mind doing this work? You should be able to hg pull -u to get to the latest.

Cheers,

Dion
Priority: -- → P4
Target Milestone: -- → Future

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Comment 5

9 years ago
Created attachment 370552 [details]
Fix for selectionChangeCase not working across rows correctly
Attachment #370458 - Attachment is obsolete: true
(Assignee)

Comment 6

9 years ago
I plan to work on the command portion of this now :)
Dion, RESOLVED INCOMPLETE is not for partially-fixed bugs!
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → NEW

Comment 8

9 years ago
Sean,

FYI: Multi-line is working for the action, but if you "undo" then it goes back and munges the lines still.
Status: NEW → ASSIGNED
(Assignee)

Comment 9

9 years ago
Odd undo was working for me, I probably messed something up before I committed. Will attempt to work on it more once I can connect to my nix box again.
Assignee: nobody → seanb
Blocks: 486912
The main bug is fixed, so marking it as RESOLVED FIXED.

The undo/redo bug has been popped out into bug 486912.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
This is a mass migration from Mozilla Labs :: Bespin to Bespin :: Editor.
Component: Bespin → Editor
Product: Mozilla Labs → Bespin
QA Contact: bespin → editor
Whiteboard: editor
You need to log in before you can comment on or make changes to this bug.