Closed Bug 485980 Opened 13 years ago Closed 12 years ago

Right clicking incorrectly fires click event on document object

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 184051

People

(Reporter: kloots, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8

In Firefox, click event handlers registered on the document object are called when the user right-clicks on an element. 

Reproducible: Always

Steps to Reproduce:
1. Goto http://yuiblog.com/sandbox/yui/v270/examples/menu/click-test.html
2. Follow instructions on the page


Expected Results:  
Click event handlers shouldn't fire for the document object if the user right-clicks on an element.
i see this indeed, with firefox 2, 3 and 3.6 nightly on windows.
Component: General → Event Handling
Product: Firefox → Core
QA Contact: general → events
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 184051
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.