Bugzilla should prefill quicksearch box when showing search results from a quicksearch

RESOLVED FIXED in Bugzilla 4.0

Status

()

P3
enhancement
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: wagnerc, Assigned: dkl)

Tracking

unspecified
Bugzilla 4.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
Build Identifier: 

After performing a search, the search terms for the just conducted search should be prefilled into the search input box.  Right now it clears the search terms.  This makes it annoying to modify ur search if u want to just tweak it.  U have to retype everything or remember to copy it to the clipboard first.  Yahoo and Google prefill the old search terms on the results page; Bugzilla should too.

Reproducible: Always

Steps to Reproduce:
1. Run any search

Actual Results:  
Search terms are cleared.

Expected Results:  
Search terms are prefilled into the search box on the results page.

Updated

10 years ago
Severity: minor → enhancement

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: Bugzilla should prefill search box when showing search results → Bugzilla should prefill quicksearch box when showing search results from a quicksearch

Updated

9 years ago
Duplicate of this bug: 498294
(Assignee)

Comment 2

8 years ago
Created attachment 444132 [details] [diff] [review]
Patch to prefill quicksearch field with previous search string from buglist.cgi (v1)

Pretty simple patch and works as expected. Doesn't affect when Bugzilla/Search/Quicksearch.pm does a redirect to show_bug.cgi meaning it does not redisplay the bug id or alias.

Please review
Dave
Assignee: ui → dkl
Status: NEW → ASSIGNED
Attachment #444132 - Flags: review?(mkanat)

Comment 3

8 years ago
Comment on attachment 444132 [details] [diff] [review]
Patch to prefill quicksearch field with previous search string from buglist.cgi (v1)

Looks good to me! Surprisingly simple. :-)
Attachment #444132 - Flags: review?(mkanat) → review+

Updated

8 years ago
Flags: approval+
Keywords: relnote
Target Milestone: --- → Bugzilla 3.8
(Assignee)

Comment 4

8 years ago
Committing to: bzr+ssh://dkl%40redhat.com@bzr.mozilla.org/bugzilla/trunk/
modified buglist.cgi
modified template/en/default/global/common-links.html.tmpl
Committed revision 7155.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 5

8 years ago
Added to the release notes in bug 604256.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.