website: from download button, direct Firefox users to different url

VERIFIED FIXED in 1.0

Status

Mozilla Labs Graveyard
Personas Plus
P2
critical
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: Suneel, Assigned: rdoherty)

Tracking

unspecified
x86
All

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
For Firefox users only, change download link on getpersonas.com to:

https://addons.mozilla.org/services/install.php?addon_id=personas

this will only work on getpersonas.com, all other links should point either to the addons listing or getpersonas.com (e.g. from the blog posts, etc.)
(Reporter)

Updated

9 years ago
Severity: normal → major
Priority: -- → P2
dupe of Bug 486147 ?

Comment 2

9 years ago
add the specifics above, or mark 486147 as the dupe.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 486147
This has been getting some attention.  I've had several folks ask me about it, including these messages on IRC:

jrmuizel>	so I went to install personas from the getpersonas.com site and I get all sorts of warnings about installing software
[14:26:24]	<jrmuizel>	the last warning asks me about installing http://releases.mozilla.org/pub/mozilla.org/addons/10900/personas_for_firefox-1.0-fx.xpi
[14:26:58]	<jrmuizel>	serving it over http:// seems pretty frightening to me

I think we should bump up its priority.
(Reporter)

Updated

9 years ago
Severity: major → critical
(Assignee)

Comment 5

9 years ago
Working on this now.
(Assignee)

Comment 6

9 years ago
FYI the irc comments are about http, not the link. All addons are served over http.
(Assignee)

Comment 7

9 years ago
Fixed. We still point to the original install url so people can right-click and download, but with JS we redirect them to the 'safe' url.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(In reply to comment #6)
> FYI the irc comments are about http, not the link. All addons are served over
> http.

Not sure what you mean by this... AMO is all-HTTPS. Are there plans to fix getpersonas.com to offer the Personas addon over https?
(In reply to comment #6)
> FYI the irc comments are about http, not the link. All addons are served over
> http.

Well, they're partly about http, but they're also about the warnings that appear when you try to install personas, which are caused by the link, if I understand correctly.
(Assignee)

Comment 10

9 years ago
(In reply to comment #8)
> Not sure what you mean by this... AMO is all-HTTPS. Are there plans to fix
> getpersonas.com to offer the Personas addon over https?

AMO serves web traffic via https, but add-ons are served off of mirrors (AFAIK), which are all http. So there is no plan to offer Personas over https.
(In reply to comment #10)
> AMO serves web traffic via https, but add-ons are served off of mirrors
> (AFAIK), which are all http. So there is no plan to offer Personas over https.

AMO passes a hash to the InstallTrigger call, though, to ensure that the linked file on the mirror is not modified.

I'll file a separate bug to cover this, I guess, since this one is resolved.
I'm seeing this, and don't know if there's something I should do to see it working:

http://www.grabup.com/uploads/ea629392319c49efc4c2b5feb45352c9.png

Please let me know how to test this, thanks!

(Reopening until we're confident it's fixed.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Suneel: Ryan looked at this today and said (iirc) that the JS isn't staying bound to the download button (for some unknown reason).

Sorry for just reopening this now; I think we should fix this before our followup push we tentatively scheduled for sometime Monday.
(Reporter)

Comment 15

9 years ago
yes, let's hold off on push, but prioritize this ahead of other bugs. Note that until we push, we are collecting incomplete metrics (Bug 486339)
(Assignee)

Comment 16

9 years ago
Fixed, return false! Arg.

Changeset 7cdc3d57aee2
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Created attachment 371296 [details]
Screenshot

Still not working here; don't know if we can test this before production, due to header-forwarding...(I've hacked HOSTS, as you can see in the screenshot).
Reopening until we figure out a way for me to test this or we decide that since Ryan tested this locally, it'll work when we push to production.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 19

9 years ago
So here's the deal:

We are having a difficult time testing this due to the combination of using a staging server and AMO's whitelist. The fix works on my local machine with AMO, which means my fix most likely works. 

We can push the fix live and if it doesn't fix the problem, we are no worse off. I recommend doing this as it is quicker than attempting to setup or configure more dev environments to see if my fix worked.
(Reporter)

Comment 20

9 years ago
QA has seen the fix on ryan's machine. I think it's safe to push the fix.
(Reporter)

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

9 years ago
FYI I just tested this on getpersonas.com and it's working :D
Created attachment 371348 [details]
Post-fix screenshot
Verified FIXED
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.