<space> is accepted as valid email id in registration form

VERIFIED FIXED in 5.0.6

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: krupa, Assigned: wenzel)

Tracking

unspecified
5.0.6

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 370299 [details]
regsitration form

steps to reproduce:
1.Go to https://addons.mozilla.org/en-US/firefox/users/register
2.Enter <space> in email id field
3.Enter other required details and submit the registration form.

expected result:
As email id is a required field,<spaces> should not be accepted as valid input.There is an informative user message.

actual result:
<space> is accepted as valid email id in registration form.User message shows-"This email address is already taken by another user." implying that <space> is allowed.
There seems to be a number of bugs associated with leaving the fields blank/empty :( See also https://addons.mozilla.org/en-US/firefox/addon/11054
(Assignee)

Comment 2

9 years ago
That used to be the case long ago. Apparently this user was imported once upon a time. In bug 493592, I deleted the user. I tried it and <space> is now throwing an appropriate error.
Assignee: nobody → fwenzel
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 493592
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 5.0.6
(Reporter)

Comment 3

9 years ago
Created attachment 379998 [details]
email id with empty string

Fred,I am able to reproduce this problem on preview.Can you please check?
(Reporter)

Updated

9 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

9 years ago
I deleted the user on preview as well (in bug 493592, they were removed in production only). I cannot reproduce the bug anymore now.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

9 years ago
works now
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.