sq.xpi for 3.0.8 uninstallable on ubuntu

RESOLVED FIXED

Status

Mozilla Localizations
sq / Albanian
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Alexander Sack, Assigned: Besnik Bleta)

Tracking

({fixed1.9.0.11})

unspecified
x86
Linux
fixed1.9.0.11
Bug Flags:
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
try to install sq.xpi from http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0.8/linux-i686/xpi/sq.xpi ... it fails. Seems there is some illegal syntax.
(Reporter)

Comment 1

9 years ago
fwiw, this is about firefox 3
Flags: blocking1.9.0.9?
Flags: blocking1.9.0.10?
(Reporter)

Comment 2

9 years ago
FWIW, the error you get is:

"Firefox could not install this item because "install-8gm..rdf" (provided by the item) is not well-formed or does not exist. Please contact the author about this problem."
The problem is a leading empty line in install.rdf, which I think is due to the trailing empty line here
  http://mxr.mozilla.org/l10n/source/sq/browser/defines.inc

Comment 4

9 years ago
Good catch.

Besnik, can you create a patch to remove the trailing empty line there? And make sure that we don't have the same problem on the hg repos?
(Reporter)

Comment 5

9 years ago
CCed Arne Goeje who found this issue during launchpad imports.
Not going to block on an uninstall failure, doubly so for a language pack with a small number of users. Will approve a patch for an appropriate release, please request approval when you have one.
Flags: wanted1.9.0.x+
Flags: blocking1.9.0.9?
Flags: blocking1.9.0.10?

Comment 7

9 years ago
Created attachment 370671 [details] [diff] [review]
fix up defines.inc, for mail, too

Jumping in with a patch for CVS.

Besnik, mind pasting a link to an hg changeset so that we can make sure this is fixed on the hg repos, too?
Attachment #370671 - Flags: approval1.9.0.10+

Comment 8

9 years ago
Checking in browser/defines.inc;
/l10n/l10n/sq/browser/defines.inc,v  <--  defines.inc
new revision: 1.7; previous revision: 1.6
done
Checking in mail/defines.inc;
/l10n/l10n/sq/mail/defines.inc,v  <--  defines.inc
new revision: 1.3; previous revision: 1.2
done

FIXED on cvs, leaving open for hg trunk and 1.9.1
Keywords: fixed1.9.0.10
(Assignee)

Comment 9

9 years ago
For trunk:   171:13f2b36d4ad0
(Assignee)

Comment 10

9 years ago
Ooops, /mail should be fixed as well. Here you are:

for 1.9.1:     172:aad318ac78c2
for trunk:     159:29a28a56432a
Since we haven't cut over into a post3.0.8 relbranch yet this fix will be in 1.9.0.9 rather than 1.9.0.10, won't it? Or do you already have a 1.9.0.9 tag in the l10n repo?
Keywords: fixed1.9.0.10 → fixed1.9.0.9

Comment 12

9 years ago
I figured that the timestamp I sent in for .8 would end up being used for .9, but there's no real conscious decision behind that.
Keywords: fixed1.9.0.9 → fixed1.9.0.10

Comment 13

8 years ago
marking FIXED, should be alright by now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.