Enhancement Request for Read Receipt on the Toolbar.

RESOLVED DUPLICATE of bug 378224

Status

--
enhancement
RESOLVED DUPLICATE of bug 378224
10 years ago
10 years ago

People

(Reporter: brian.edge, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 GTB5 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.21

"Enhancement Request" for Mozilla Thunderbird (current version: 2.0.0.21).

In addition to the "Options" menu, to provide an option of a customisable "sticky drop-list button" on the toolbar of any open "Outgoing mail edit window" to easily change the default "Read Receipt" setting on a per email basis.  On opening a new mail edit window, the button appearance would indicate as per the config default, ie, appear "pressed" if the default was set to "send a receipt request" and "un-pressed" if the default was to "not send a request" or "Ask".  Clicking the "buttons side down arrow" would list the 3 choices of "Request", "Don't Request" and "Ask".  If changed from the default setting and the mail is saved before it is sent, the current state of the request would be saved with the mail and restored upon re-opening.
(This would allow one to be able to easily request read receipts for important emails, but not clutter the system for lesser significant mails, jokes, etc.  Also being a visible Button on the toolbar, it would tend to remind the user to to change its status if required).

Reproducible: Didn't try

Steps to Reproduce:
1.None
2.
3.
Actual Results:  
Nothing

Expected Results:  
Not yet implemented

None
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378224
You need to log in before you can comment on or make changes to this bug.