gl.xpi for 3.0.8 has a buggy Unicode character

RESOLVED FIXED

Status

Mozilla Localizations
gl / Galician
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Arne Goetje, Unassigned)

Tracking

({fixed1.9.0.15})

unspecified
x86
Linux
fixed1.9.0.15

Firefox Tracking Flags

(status1.9.2 beta5-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030814 Iceweasel/3.0.7 (Debian-3.0.7-1)
Build Identifier: 

In locale/gl/global/layout/MediaDocument.properties:

InvalidImage=Non é posíbel mostrar a imaxe \u201%S\u201d porque contén erros.

Here is an invalid Unicode character (\u201 instead of \u201c).
This prevents the translation from being imported into Ubuntu language-packs for Galician.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 370425 [details] [diff] [review]
patch for MediaDocument.properties

Comment 2

9 years ago
broken translation on stable branch.

Comment 3

9 years ago
Hi:

My name is Frco. Javier, and I've been recently incorporated to the gl localization team.

I think that the patch created by Arne Goetje it's ok, but do I need to submit/upload this file to any repositories?? or can we close this bug?? 

Thanks in advance.
Frco. Javier Rial

Comment 4

9 years ago
I think I cand auto-reply myself.

Searching for this file, I found it in our gl repo, at this location:
gl/dom/chrome/layout/MediaDocument.properties.

Edited the file and applied the patch.

Committed to our repository.
Thanks.

Comment 5

8 years ago
This it's fixed now.

Can we do something here?

Thanks.
Frco. Javier Rial

Comment 6

8 years ago
Do we still need to fix this on 3.0.x? There still seems to be roughly 50% of the gl users on that.

If so, please request approval1.9.0.15. On the cvs tree, we're still working on a process of approval per patch.

If not, feel free to close the bug, I just granted you the priviledges to actually do that.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

8 years ago
I saw that there are still a lot of galician users using firefox 3.0.* (I did the langpack for gl that's upload in AMO, and from AMO stats, I can see that it's still in use..).. also, the latest Ubuntu LTS is still using firefox 3.0.* ( I don't know if they are planning to provide latest firefox3.5.*)

.. so I would ask to request for approval 1.9.0.15

Thanks.
Frco. Javier Rial

Comment 8

8 years ago
Please go to the attachment details and set the approval1.9.0.15 flag to '?' for that.

Updated

8 years ago
Attachment #370425 - Flags: approval1.9.0.15?

Comment 9

8 years ago
Done.
Again, a lot of thanks, Axel

Updated

8 years ago
Attachment #370425 - Flags: approval1.9.0.15? → approval1.9.0.15+

Comment 10

8 years ago
Comment on attachment 370425 [details] [diff] [review]
patch for MediaDocument.properties

a=me for landing in cvs for 3.0.15.

Please use a good check-in comment like "bug 486322, fix buggy unicode character, a=l10n@mozilla.com".

After landing, please add the fixed1.9.0.15 keyword, and test the resulting 1.9.0.x builds from ftp. Once the fix is verified on the builds, change the fixed1.9.0.15 keyword to the verified1.9.0.15 keyword.

Comment 11

8 years ago
http://bonsai-l10n.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=l10n/gl/dom/chrome/layout&command=DIFF_FRAMESET&file=MediaDocument.properties&rev1=1.1&rev2=1.2&root=/l10n, landed on CVS.
Keywords: fixed1.9.0.15

Comment 12

8 years ago
This bug is showing up on 1.9.2 again, can you still fix it there?

Comment 13

8 years ago
landed, fixed:

http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/gl/file/8258b8d4815d/dom/chrome/layout/MediaDocument.properties

Comment 14

8 years ago
I bumped your signoff to http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/gl/pushloghtml?changeset=8258b8d4815d to get this into our 3.6 builds, marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
status1.9.2: --- → final-fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.