Closed Bug 486341 Opened 13 years ago Closed 13 years ago

History filter doesn't respect history sorting

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 392497

People

(Reporter: tmptgr, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

I was trying to find a Wikipedia page i visited last week, so i sorted the history sidebar by "date last visited". Seeing that there were too many results, i put "wiki" in the filter bar, but was dismayed at finding that the new result list only displays sorted alphanumerically. Changing the sorting again erases my search term!

Reproducible: Always



Expected Results:  
Don't alphabetically sort filter results when the sort isn't set to "by website".

Also don't erase my input for no reason. (Separate bug, but closely related and easily fixed.)

It would be best if i could sort my filtered results.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392497
You need to log in before you can comment on or make changes to this bug.