after crash, I get two tabs (instead of just one, about:sessionrestore)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: sspitzer, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
after crash, I get two tabs (instead of just one, about:sessionrestore)

my two tabs are:

about:sessionrestore and http://en-us.www.mozilla.com/en-US/firefox/3.1b3/whatsnew/ and http://en-us.www.mozilla.com/en-US/firefox/3.1b3/whatsnew/ is selected.

here comes a screen shot.

is this by design? 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)
(Reporter)

Comment 1

10 years ago
Created attachment 370580 [details]
screen shot
Was about:sessionrestore open before the crash? Otherwise I don't think this is by design...

Note, if it was open a bit before the crash, I think there's a bug out there about sessions being restored incompletely/wrongly due to not being able to write to disk in a crash...
(Reporter)

Comment 3

10 years ago
> Was about:sessionrestore open before the crash? 

no, it was not.
(Reporter)

Comment 4

10 years ago
also, for the two times I've seen about:sessionrestore this happened, which is why I asked if it was by design.

Comment 5

10 years ago
* Did you get that other page after normal startup as well?
* Did you just update Firefox (and it didn't get a chance to remember not to show the first run page again)?
* Do you have otherwise issues with prefs not sticking to their set value?
* Does that profile have any extensions installed?

IOW: Do you have steps to reproduce this issue for us?
Status: NEW → UNCONFIRMED
(Reporter)

Comment 6

10 years ago
> * Did you get that other page after normal startup as well?

No.

> * Did you just update Firefox (and it didn't get a chance to remember not to
> show the first run page again)?

No, I don't think so.

> * Do you have otherwise issues with prefs not sticking to their set value?

No, at least I've not noticed that.

> * Does that profile have any extensions installed?

I'll double check, but I don't think so.

> Do you have steps to reproduce this issue for us?

Unfortunately, I don't.  But if you know of a way to force a crash, I can try that and let you know what tabs I get on restore.

Comment 8

9 years ago
This happened to me. Try these steps to reproduce:

1. Set browser.sessionstore.max_resumed_crashes to 0.
2. With one tab open, crash Firefox.
3. Press "Restart Firefox" when the Crash Reporter dialog comes up.

Comment 9

9 years ago
Created attachment 403853 [details]
screen shot 2

On Firefox restart, Session Restore asks about restoring the tab and at the same time the tab is automatically restored (without the user clicking on "Restore Session").

Comment 10

9 years ago
I neglected to mention a confounding factor in my case. I launched Firefox with a URL on the command line:

firefox.exe http://www.hulu.com/the-tonight-show-with-conan-obrien

So maybe Crash Reporter's "Restart Firefox" button is relaunching Firefox using the original command line string with the URL?

Revised steps to reproduce:

0. Launch Firefox with a URL as a command-line argument. For example:
   firefox.exe https://bugzilla.mozilla.org/show_bug.cgi?id=486465
1. Set browser.sessionstore.max_resumed_crashes to 0.
2. With one tab open, crash Firefox.
3. Press "Restart Firefox" when the Crash Reporter dialog comes up.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100322 Minefield/3.7a4pre

Using the steps in comment 10 I cannot reproduce this behaviour.  Resolving WORKSFORME.  Please reopen with more specifics if you can reproduce on the current nightly build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.