Focus switches from body text input to recipient text input

RESOLVED DUPLICATE of bug 329482

Status

--
minor
RESOLVED DUPLICATE of bug 329482
10 years ago
9 years ago

People

(Reporter: agx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.9.0.7) Gecko/2009032022 Iceweasel/3.0.7 (Debian-3.0.7-1)
Build Identifier: 2.0.0.19

When composing new mail the focus for text input is intially in the message body text input then switches to the recpient text input. As a result when one hits "CTRL-N" to compose new mail and immediatly starts typing the recipient's address, the first letters of the recipient's address may end up in the mails body.

Reproducible: Sometimes

Steps to Reproduce:
1. Hit CTRL-N or the "Write" Toolbar button
2. immediatly start typing
Actual Results:  
The first few letters of the recpient's address may end up in the mails body.

Expected Results:  
The focus should be set to the "To" recipients field immediately so that all text ends up in the recpient's address.
Can't reproduce this on a tb3 nightly.

agx: can you try a build from 
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Whiteboard: CLOSEME 2008-05-08
Version: unspecified → 2.0

Updated

10 years ago
Whiteboard: CLOSEME 2008-05-08 → CLOSEME 2009-05-08
(Reporter)

Comment 2

10 years ago
I can still reproduce this easily with a TB3 build from 20090422. Just hit the "write" button in the toolbar and start pressing a key frequently. You'll see that in about 50% of the causes some letters end up in the body and then get entered in the "To:" field.

Comment 3

10 years ago
yes, itt does work that way.  Tthere should be an existing bug on this.
Whiteboard: CLOSEME 2009-05-08 → dupeme

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 329482
You need to log in before you can comment on or make changes to this bug.