theradiochick.com - RSS feed has useless <link> and <guid> elements

RESOLVED WONTFIX

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: Yuri, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9.0.7) Gecko/2009031219 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9.0.7) Gecko/2009031219 Firefox/3.0.7

This happens for other rss feeds too.
Firefox reads the website location and just goes there instead of opening the mp3 file itself.


Reproducible: Always
Clicking on the page is suppose to bring you to the page to subscribe to the feed, which it does. If you look at the feed, the MP3 files are not part of the feed itself, just the headlines for each day. 

This should be a developer-evangelism bug.
Moving this bug to the RSS component.
Component: General → RSS Discovery and Preview
QA Contact: general → rss.preview
Assignee: nobody → english-us
Component: RSS Discovery and Preview → English US
OS: FreeBSD → All
Product: Firefox → Tech Evangelism
QA Contact: rss.preview → english-us
Hardware: x86 → All
Summary: Firefox opens URL instead of the mp3 file when I click on the entry under RSS menu item → theradiochick.com - RSS feed has useless <link> and <guid> elements

Comment 3

8 years ago
Is there a feed-reader that actually *does* play the MP3 files without going to the site? This doesn't sound so much like "evangelism" as "education", from the description so far. We can't help it if webmasters or have unrealistic expectations of what something is capable of doing :-p
(Reporter)

Comment 4

8 years ago
Currently ff shows the menu of all available podcasts, clicking on each of which just brings user to the same home page. From this homepage, use can navigate to the particular podcast.

When I look a the file I see <guid> elements that looks like supposed to point to particular files, but they seem to be broken.

From RSS spec I see that guid tag is just a unique string, and this feed seems to misinterpret it.
And link tag is supposed to point to RSS.

So looks like it's mostly a broken RSS. Nonconforming to a standard.

Am I right?
(Reporter)

Comment 5

8 years ago
RSS documentation http://www.rssboard.org/rss-specification seems faulty, suggesting that guid is just a unique string, but giving some URL as an example. So people may confuse this with URL of a file, not just a string.

I believe the only thing that's wrong in this PR is the misformed feed showing too general 'link' tags.

If that's true PR can be closed.

Comment 6

8 years ago
Not really a TE issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.