Closed Bug 486566 Opened 12 years ago Closed 12 years ago

Addon upgrade UI should not need extra click after successfup upgrade

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 397493

People

(Reporter: timr, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

When addon upgrades are detected at launch time, at least two user actions are required: one to approve the upgrade(s) (which is fine), and one to acknowledge the "installation went OK" notice.  That second click is unnecessary.  If the upgrades were successful, just launch the browser.  That is, after all, the action I originally wanted.  If there were errors, then sure, let me know.

Yes, this is very picky.  Yes, you have more important problems.

Reproducible: Always

Steps to Reproduce:
1. Wait until an addon has been upgraded.
2. Launch Firefox.
3. Say "OK, do the upgrade".

Actual Results:  
I must click again to get the browser up.

Expected Results:  
A successful upgrade should complete silently.
Bug 447570 is on installs, would presumably do the same for updates. Marking dupe, please comment if you think wrong
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Component: General → Add-ons Manager
OS: Windows XP → All
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Hardware: x86 → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 447570
You're right.  Sorry, I did an extensive search for similar reports, but my search-fu failed to find 447570.
No problem.
Status: RESOLVED → VERIFIED
bug 447570 has nothing to do with the update dialog this bug is talking about.
Duplicate of bug: 397493
You need to log in before you can comment on or make changes to this bug.