Edit Draft message brings up composition window with wrong background color and lose HTML formatting

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: u331436, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090403 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090403 SeaMonkey/2.0b1pre

Regression between 20090402 and 20090403:
Editing in HTML a draft message (Drafts folder) brings up a broken text with usually yellow background.
Similar to bug 466360


Reproducible: Always

Steps to Reproduce:
1.Compose message in HTML
2.close and save message
3.re-open (Edit draft) the message: HTML mingled, collors, fonts settting and formatting lost.
(Reporter)

Comment 1

10 years ago
This is caused by the presence of a signature certificate (see bug 466360)
(Reporter)

Comment 2

10 years ago
Did some additional testing to confirm:
- Problem occur when signing certificate is used
- Problem do not occur without signing certificate
based on the same message text and HTML formatting.
(Reporter)

Comment 3

10 years ago
Also tried and confirmed the bug on Linux platform
OS: Windows XP → All
Version: unspecified → Trunk
Does this happen with a simple test message or is a bit more text formatting required? This seems to work fine here with a current comm-central/1.9.1 build: I saved a signed HTML message with text formatting to Local Folders and on my local IMAP account. Both times editing the draft worked fine.
(Reporter)

Comment 5

10 years ago
More testing shows that this appears with simple HTML (table, embedded images) + signature certificate, stored then re-edited from either Drafts folders or Template folder.
More complex HTML (CSS) also shows the problem.
Next validation is to use a clean profile.
Related: Bug 392558, that one is no regression though.
Ok, so it looks like to reproduce the bug, you need to for example embed a image and leave the "Attach this image to the message" checkbox checked. Then editing the saved draft (signed) will have a yellow background and a broken image. Now another question is: Is this really a regression as Bug 392558 described a very similar bug which was already present in Thunderbird 2?
(Reporter)

Comment 8

10 years ago
Good point Frank !
I walked back on my own tracks to figure out if we are in a SM regression (starting April 3rd) or into a duplicate of Bug 392558 and I rather think now it might be related to the Thunderbird bug.
I started to use embedded images then (April 3rd or so) into my messages (save as drafts). As I always use my S/MIME cert, this led me to think I was back into something similar to bug 466360, I thought "regression", although there was something new in my Email composition (images, CSS...).
Hope this helps...
(Reporter)

Updated

10 years ago
Flags: wanted-seamonkey2?
(Reporter)

Comment 9

10 years ago
I see today (nightly 20090420) that the bug is now solved. I don't know what could have solved the issue.
Not sure if TB and bug 392558 is also in the same case though
Closing this one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
When the bug which fixed another bug is not known, we normally resolve the bug as wfm. I did some quick testing, this was probably resolved by some check-in between 2009-04-15 and 2009-04-16.
Resolution: FIXED → WORKSFORME
Flags: wanted-seamonkey2?
You need to log in before you can comment on or make changes to this bug.