If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browserWidth not defined

VERIFIED WONTFIX

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: Dave, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Build 2000081105/Linux

At http://www.ford.com mozilla prints the following error message:

JavaScript error:
http://www.ford.com/ line 63: browserWidth is not defined

I don't see this variable defined anywhere in their code, but the page renders
on NS4.7x and IE5. Is this supposed to be predefined by the browser?
(Assignee)

Comment 1

17 years ago
The reason for this problem is that www.ford.com relies on invalid browser
sniffing code (document.layers) that doesn't detect Netscape6 and because of
this browserWidth is never set and mozilla complains about that and stops the
execution of the script. There's really nothing we can do about this,
www.ford.com needs to be updated to support Netscape6.

Marking WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → WONTFIX

Comment 2

17 years ago
WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.