Tagging bookmarks or history items via cut&paste into tag containers clears bookmark name

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
9 years ago
3 days ago

People

(Reporter: whimboo, Unassigned)

Tracking

({dataloss})

3.0 Branch
dataloss
Points:
---
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [could be fixed by bug 484578])

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090403 Minefield/3.6a1pre ID:20090403030700

Browsing some sites and trying to tag a bookmark or history item via cut&paste into a tag container clears the bookmark name. Pasting it into a bookmark folder instead let the bookmark name persist.

1. Open http://www.nytimes.com/
2. Open all history.
3. Check the item name: "The New York Times - Breaking News, World News & Multimedia"
3. Cut history item (Cmd/Ctrl+x) from all history folder
4. Select a tag under the tag container and press Cmd/Ctrl+v

After step 4 the bookmark name is cleared. This happens for history items and already existing bookmarks. Not tested with Firefox 3.0.8 yet.

Comment 1

9 years ago
Same Issue
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090403 Minefield/3.6a1pre ID:20090403050211

Paste command not available in Firefox 3.0.8,
(Reporter)

Updated

9 years ago
Summary: Tagging bookmarks or history item via cut&paste into tag containers clears bookmark name → Tagging bookmarks or history items via cut&paste into tag containers clears bookmark name
Version: 3.1 Branch → 3.0 Branch

Updated

9 years ago
Assignee: nobody → ddahl
(Reporter)

Comment 2

9 years ago
Asking for blocking because it's a dataloss issue.
Flags: blocking-firefox3.5?
when you cut from history you are removing the visit, when you paste your are pasting an unvisited url, for which we don't have a title anymore.
Unless we want to create a small workaround that saves title before cut and restore at paste, fixing this would require fixing Bug 484578, doing the latter is clearly the preferred way.
and in case of cut & paste a bookmark into a tag container, it's not much clear what user is trying to do, cut is going to remove the bookmark, while paste is going to create a new bookmark in unfiled folder, so that would end up being "tag bookmark and then move it to unfiled bookmarks". Probably the better way to handle that is to ignore cut and execute a simple copy leaving the bookmark in place.
Not blocking as this isn't a new regression (isn't this part of the release fun?) but nominating for Firefox 3.6.

Marco: are you saying that this would be fixed by a fix to bug 484578? If so, please add that to the WB?
Flags: blocking-firefox3.5? → blocking-firefox3.5-
A fix to bug 484578, whenever it would copy to the new item before removing the old item, would fix this, but comment 4 issue could require an additional special handling.
Whiteboard: [could be fixed by bug 484578]
Flags: in-testsuite?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Flags: in-testsuite?

Updated

5 years ago
Assignee: ddahl → nobody
At some stage along the way I believe we've fixed this. Just tested on latest nightly, if you try to copy and paste into a tag, then the title and description are preserved, as well as existing tags.
Status: NEW → RESOLVED
Last Resolved: 3 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.