New variable: MOZ_FS_LAYOUT should be used instead of OS or Toolkit to determine file system layout

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
Build Config
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Jeremy Huddleston, Assigned: Jeremy Huddleston)

Tracking

Trunk
mozilla1.9.2a1
All
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_6; en-us) AppleWebKit/530.5+ (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: 

Darwin/gtk uses the traditional UNIX layout, but there are places in the build that assume Darwin = bundle.  The cleanest solution is to create a single new variable to describe this that has options for:

traditional : The traditional unix layout (placing the startup script in bin, libs, etc in mozilla_five_home, etc)
bundle : Create a NextStep / Darwin / OSX style bundle (ie: Firefox.app)
winnt : windows stuff (I have no real understanding of how that works, but I assume we'd replace most of the OS=WINNT with this check)



Reproducible: Always
(Assignee)

Updated

9 years ago
Blocks: 485856
(Assignee)

Updated

9 years ago
Blocks: 486036
(Assignee)

Updated

9 years ago
Blocks: 485863
(Assignee)

Updated

9 years ago
Blocks: 485827
(Assignee)

Updated

9 years ago
No longer blocks: 485827, 485856, 485863, 486036
(Assignee)

Updated

9 years ago
Blocks: 485863
(Assignee)

Updated

9 years ago
Blocks: 485827
(Assignee)

Updated

9 years ago
Blocks: 486036
(Assignee)

Updated

9 years ago
Blocks: 485856
Status: UNCONFIRMED → NEW
Component: General → Build Config
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → build-config
(Assignee)

Updated

9 years ago
Assignee: nobody → jeremyhu
Hardware: PowerPC → All
(Assignee)

Updated

9 years ago
Blocks: 486890
(Assignee)

Updated

9 years ago
No longer blocks: 486890
(Assignee)

Updated

9 years ago
No longer blocks: 485863
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

9 years ago
What should the values of this variable be for OS2 and BeOS?
Blocks: 487371

Comment 2

9 years ago
We would probably *not* replace OS=WINNT with this, since most of the windows checks are for which files to build (OS integration, etc) and not packaging details. I think for now we only need two values, "unix" and "bundle".
(Assignee)

Comment 3

9 years ago
Created attachment 372025 [details] [diff] [review]
possible patch to add MOZILLA_FS_LAYOUT to configure.in

Here's a patch to consider.  The one thing I'm not too sure about is the transition of -DNO_X11 from HOST_CFLAGS to TK_CFLAGS.

I was having some trouble figuring out what HOST and TARGET were for since they seem to be breaking convention that I'm used to (BUILD = host you're building on, HOST = host the code will run on, TARGET = host built apps will generate code for).  Therefore, I don't understand why there is anything to do with TARGET in configure.in, and it looks like TARGET is what HOST should be (the platform mozilla will run on) and HOST is what BUILD should be?
Attachment #372025 - Flags: review?(benjamin)

Comment 4

9 years ago
Comment on attachment 372025 [details] [diff] [review]
possible patch to add MOZILLA_FS_LAYOUT to configure.in

Yeah, our configure uses host|target for build|host due to longstanding (1998) tradition.
Attachment #372025 - Flags: review?(benjamin) → review+

Comment 5

9 years ago
Created attachment 372413 [details] [diff] [review]
Updated to trunk, reverted NO_X11 changes, rev. 1
[Checkin: Comment 10]

The patch has been bitrotted by several intervening changes (removing the old mac-cairo codepaths, as well as removing all references to FlatCarbon). Also I've reverted the changes for -DNO_X11, because that is specific to HOST_CFLAGS: it's used in config/mkdepend/def.h and I think we can happily state that you don't need X11 to build mkdepend on Darwin, no matter whether you end up targeting darwin-cocoa or x11/gtk.
Attachment #372413 - Flags: review?(jeremyhu)
(Assignee)

Comment 6

9 years ago
Comment on attachment 372413 [details] [diff] [review]
Updated to trunk, reverted NO_X11 changes, rev. 1
[Checkin: Comment 10]

Thanks, that looks good.  Is this and the related changes only going to be targeted at trunk?  I'd like to get it into 1.9.1 as well, so I can reduce our patchset size.
Attachment #372413 - Flags: review?(jeremyhu) → review+
(Assignee)

Comment 7

9 years ago
Although in retrospect, we might want to name it MOZ_FS_LAYOUT instead of MOZILLA_FS_LAYOUT for better naming consistency with the other variables...
(Assignee)

Comment 8

9 years ago
Created attachment 372571 [details] [diff] [review]
updated 1.9.1 patch

This is an updated patch against 1.9.1 which addresses changes your made in your trunk patch and changes the name to MOZ_FS_LAYOUT to match the naming style of similar variables
Attachment #372025 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Summary: New variable: MOZILLA_FS_LAYOUT should be used instead of OS or Toolkit to determine file system layout → New variable: MOZ_FS_LAYOUT should be used instead of OS or Toolkit to determine file system layout
(Assignee)

Updated

9 years ago
Duplicate of this bug: 485856

Comment 10

9 years ago
http://hg.mozilla.org/mozilla-central/rev/58460d86223d
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Comment on attachment 372571 [details] [diff] [review]
updated 1.9.1 patch


You should either request review+approval or obsolete this patch.
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
(Assignee)

Updated

8 years ago
Attachment #372571 - Attachment is obsolete: true
Attachment #372413 - Attachment description: Updated to trunk, reverted NO_X11 changes, rev. 1 → Updated to trunk, reverted NO_X11 changes, rev. 1 [Checkin: Comment 10]
Blocks: 506493
You need to log in before you can comment on or make changes to this bug.