Recurring reproducible crashes in Camino 2.0b2 [@ libobjc.A.dylib][@ gfxAtsuiFont::GetCharWidth] from an unknown cause

RESOLVED DUPLICATE of bug 459711

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 459711
9 years ago
7 years ago

People

(Reporter: Armen Abrahamian, Assigned: jtd)

Tracking

({crash})

1.9.0 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I've recently begun experiencing repeated crashes in Camino 2.0b2 (also reproduced in a nightly build from April 3rd).

One page that repeatedly produced a crash tonight was the following: http://www.yelp.com/biz/hotel-cafe-los-angeles

The crash dump for this crash from Apple's crash reporter can be found here: http://pastebin.mozilla.org/640224

Based on a hunch in the IRC channel, I checked in Font Book for corrupt fonts and found none, only some warnings for duplicates.

Anecdotally many of the pages that have seemingly caused the crash also had Flash components or Flash video players embedded in them, but I'm not entirely certain that this was the case across the board.

Camino Version String: Version 2.0b2 (1.9.0.8pre 2009022317)
Running on a MacBook Pro 2.5GHz on OS X 10.5.6.
Flags: camino2.0b3+

Comment 1

9 years ago
I had two very similar crashes on the morning of April 1 (! no joke), loading: http://daringfireball.net/linked/.
The page would start loading, hang briefly and then crash. At the same time, Safari 4b and the latest WebKit nightly, and Firefox 3.0.9pre would display the page basically blank: no text was displayed at all. The latest Minefield nightly had no such problem(s).

I'll note here that each browser would call the default sans-serif font for that daringfireball page (which in my case is Helvetica Neue). Its stylesheet specifies: Verdana, Bitstream Vera Sans, sans-serif. Verdana is disabled/removed on all my computers, Bitstream Vera is not installed currently.

Console log would show - for each browser- repeated entries: <Error>: GCGetStrikeMetrics failed: error 4.

I restarted the Mac. The problem vanished.
(Since then I also ran disk utility - verify disk - no problems found; and Onyx, cleaned out all fonts caches.)

Note also: the evening before those two crashes, I had installed Neo Office 3. That was the only noteworthy change to the machine.

Comment 2

9 years ago
Created attachment 371228 [details]
crash log

crashlog, comment 1.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408106

Updated

9 years ago
Status: RESOLVED → VERIFIED
Flags: camino2.0b3+
John has been working on figuring out if we can prevent these sorts of crashes (see bug 459531, bug 459711, and bug 479771), and since Armen can more-or-less reliably crash, we should investigate this one, even if it's ultimately a dupe of one of the other three.
Status: VERIFIED → REOPENED
Component: General → GFX: Thebes
Product: Camino → Core
QA Contact: general → thebes
Resolution: DUPLICATE → ---
Summary: Recurring reproducible crashes in Camino 2.0b2 from an unknown cause → Recurring reproducible crashes in Camino 2.0b2 [@ libobjc.A.dylib][@ gfxAtsuiFont::GetCharWidth] from an unknown cause
Target Milestone: Camino2.0 → ---
Version: Trunk → 1.9.0 Branch
(Reporter)

Comment 5

9 years ago
After reading through the dupe bugs I thought it would prudent to mention that I also installed OpenOffice.org v3 around the same time that these crashes started.

Also, as far as repro it's not in the best sense since the same page won't cause the crash all the time, only within short windows of time. But I am finding at least one page every day or two that triggers it for the past week or so so hopefully I can provide some insight into the issue for you guys.
Armen noted in the channel that he had recently installed NeoOffice 3 and OpenOffice.org 3; while NeoOffice no longer ships the corrupt DejaVuSansExtraLight.tff font, OpenOffice.org persists in shipping it.

I had Armen pull that font out of his OOo bundle and reset font caches; if his crashes go away, then this is just bug 459711 again.
Severity: normal → critical
Keywords: crash
(Assignee)

Updated

9 years ago
Assignee: nobody → jdaggett
Armen, you haven't see the random crashes since I had you pull those fonts, have you?  If you haven't, let's go ahead and dupe this to bug 459711.

If you have...um :/
(Reporter)

Comment 8

9 years ago
Nope. The crashes abated when I deleted the fonts that OpenOffice came with. Well, I just pulled OpenOffice entirely from my system. :)

We're good to go. Blame is on OOo. Thanks for the help.

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459711
Crash Signature: [@ libobjc.A.dylib] [@ gfxAtsuiFont::GetCharWidth]
You need to log in before you can comment on or make changes to this bug.