Closed Bug 487058 Opened 16 years ago Closed 16 years ago

Page does not always get redrawn on Flickr

Categories

(Core :: General, defect)

1.9.0 Branch
x86_64
Windows Vista
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 474886

People

(Reporter: thomas, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

If you navigate through the photo pages in your flickr contacts or groups, the background does not get redrawn always. You have to scroll down or switch  between windows/tabs to see a correct displayed website. Take a look at the attached screenshot.

I had exactly the same issue with flickr in FF 3.1b1/b2 but not anymore in
later 3.1 releases or nightlys. There this bug is already fixed (bug 474886).

But in FF 3.0.8 this problem still exists. 

Thanks in advance.

Kind Regards
Thomas Babut

Reproducible: Sometimes

Steps to Reproduce:
1. Start Firefox
2. Clean your Firefox Cache
3. Open www.flickr.com
4. Log into your Flickr account
5. Click on the contacts link in the top
6. Navigate to next page with photos
Actual Results:  
The background of the page is not redrawn completely. So you see the partial content of the previous page.

Expected Results:  
A correct displayed website.
Version: unspecified → 3.0 Branch
Product: Firefox → Core
QA Contact: general → general
Version: 3.0 Branch → 1.9.0 Branch
Thomas, can you reproduce it with any of the former releases of Firefox 3? Would be great if you could check it with Firefox 3.0 and any in-between release.
I am pretty surprised, but this problem is already in FF 3.0.0. See the attached screenshot.

Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0 (.NET CLR 3.5.30729)
Ok, there is one big favor you could do us. Would you have time to step back to Firefox 2 and check if it happens there too? Would be great to know if it regressed between Fx2->Fx3. If it is still visible there please step back to former releases. Thanks!
Henrik, can you kick off a tryserver build with the patch in bug 474886 (if it applies to 3.0) to see if it fixes this bug or if this is a separate issue?
Fascinating :)

Here are my results (tested it multiple times to be really on the safe side):

2.0.0.20 OK
3.0b1 OK
3.0b2 OK
3.0b3 BROKEN

So it happened in between 3.0b2 and 3.0b3 somewhere. Didn't tested all nightlys between the two. ;)
I'm not able to see the problem with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.7pre) Gecko/2009020405 GranParadiso/3.0.7pre

Could it be something x64 related?

(In reply to comment #5)
> Henrik, can you kick off a tryserver build with the patch in bug 474886 (if it
> applies to 3.0) to see if it fixes this bug or if this is a separate issue?

Jeff, the fix we had on trunk and 1.9.1 fixes something which seems to exist on 1.9.0 too. I haven't checked before but here it is visible:

http://mxr.mozilla.org/firefox/source/gfx/cairo/cairo/src/cairo-gstate.c#706

No idea if this could fix this too and sadly I don't have time to update the patch to push it to tryserver. Would you have time for?
For testing purposes I've created a new profile with FF 3.0.8 and started without any extensions. But it doesn't resolve this issue. So it's not a profile thing.
A friend of mine has got FF 3.0.8 on Vista 32-bit and doesn't have this problem. On my girlfriends laptop with FF 3.0.8 and Vista 32-bit Flickr is also working fine. All three of us have a Nvidia graphics card.

So perhaps this has really something to do with x86_64, but it's only a guess.
As given by bug 474886 comment 44 the patch for 1.9.1 was checked in around 2009-02-06 14:34:22 PDT. Thomas, could you run a test on Vista64 with 1.9.1 builds from 2009-02-06 and 2009-02-07? Does the first build show this flickr problem?
I just did some tests with these two builds:

2009-02-06: BROKEN
2009-02-07: OK
Jeff, that means we should get the patch from bug 474886 updated to 1.9.0 and land it there too? Sam, would that be possible?
Status: UNCONFIRMED → NEW
Ever confirmed: true
You're welcome to nominate it with an appropriate patch. I'd like Jeff and Vlad to comment though. And, really, this is a dupe.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Yes it is. Thanks Thomas for your help.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: