Query result as xml output

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Query/Bug List
P3
enhancement
RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: Shiva Thirumazhusai, Assigned: Dawn Endico)

Tracking

unspecified
Bugzilla 2.18
x86
Windows NT
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I have modified the buglist.cgi to output XML. I am attaching the patch.

Adding xmlout=1 to the URL (buglist.cgi?xmlout=1) the result will be xml.
(Reporter)

Comment 1

18 years ago
Created attachment 12791 [details] [diff] [review]
Query result as XML output

Comment 2

18 years ago
marking as possible inclusion into 2.12
Whiteboard: 2.12
Namachi: Any chance of getting this patch reposted as a unified (-u) diff?  
There's already been enough changes to buglist.cgi since this patch was posted 
that it's too stale to apply without context.

cvs -z3 diff -u buglist.cgi
(Reporter)

Comment 4

18 years ago
I am in the process moving back to MountainView,CA. I will post the new version
next week.( I don't have the machine with me). 

Comment 5

17 years ago
any eta on getting this patch updated? 
(Assignee)

Comment 6

17 years ago
reassigning to shiva since we're waiting on him
Assignee: endico → namachi
(Reporter)

Comment 7

17 years ago
Created attachment 14970 [details] [diff] [review]
Patch created using :- cvs -z3 diff -u buglist.cgi
(Reporter)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 8

17 years ago
endico -- namachi doesn't have write access, and you know more about xml than I
do.  Could you review this and either commit or post-2.12 it?
Assignee: namachi → endico
Status: ASSIGNED → NEW

Updated

17 years ago
Keywords: patch, review

Comment 9

17 years ago
I am moving this to post 2.12, no response.
Whiteboard: 2.12 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16

Updated

17 years ago
Blocks: 82878

Comment 11

17 years ago
IMHO, this really isn't the right way to do this; it should be done with the
perl XML libraries. If I submitted a patch that used those, would it be
accepted? Or is adding another dependency verboten? 
-> Bugzilla product, Query component.
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Whiteboard: 2.16
Version: other → unspecified
This can be done using new templates, right? :-)

I'm beginning to think that templates are the answer to everything...

Gerv

Comment 14

16 years ago
Yeah, the best way to do this ATM would be to use the template stuff. Do you
have patches for that yet, Gerv?
Myk is templatising buglist.cgi.

Gerv
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 17

16 years ago
Is this the same as #110770?

Comment 18

16 years ago
*** Bug 110770 has been marked as a duplicate of this bug. ***
The fix for bug 103778 will make the fix for this one trivial (although it will
require a new patch).  Making that bug block this one.
Depends on: 103778

Updated

16 years ago
Blocks: 115642
The templatized buglist.cgi (bug 103778) has been checked in.  It includes RDF
output (&format=rdf), which is well-formed XML.  Does that resolve this bug, or
is there a need for some different flavor of XML?

Comment 21

16 years ago
Myk: from where I stand, I think the question is 'how complete is the RDF'? Does
it have all fields available via the standard interface? If so, then I'd think
that this is complete. [Also, doesn't having RDF close out 82878?]
The RDF version does indeed include all the fields available via the HTML
interface, but it isn't valid RSS, since RSS is a very specific dialect of RDF.
 The templatization fix makes in very easy to add RSS support, however.

Comment 23

16 years ago
OK, I'm closing this, based on the exchange between Myk and I some time ago.
Please reopen if I'm overstepping my bounds :) 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.