typing an application name in the location bar doesn't launch the app

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: rcampbell, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [snarkfest][loldietrich][icanhaspony?])

(Reporter)

Description

10 years ago
I tried typing "telephone" in the location bar and expected the app to launch, but instead, it just did a google search for telephone.

Steps to reproduce:

1: Launch Firefox
2. Type an application name in the Location Bar (aka The Awesomebar)
3. hit enter

Expected results:
The application should launch

Actual results:
I got a google search results page. Depending on the search and the contents of the awesomebar, you might get taken to a webpage.
Uhm, since when is the location bar supposed to launch applications for users? I think that would be unexpected behavior.
Flags: blocking-firefox3.5-
Severity: normal → enhancement
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Uhm, since when is the location bar supposed to launch applications for users?
> I think that would be unexpected behavior.

Since I tried typing an application in the location bar thinking I was in Spotlight, I guess.

http://twitter.com/robcee/status/1464918061

Comment 3

10 years ago
Spotlight didn't launch a google search either ...  Some webbrowsesr really want to take over the enite operating system, but we're not there yet.
(Reporter)

Comment 4

10 years ago
can we file bugs on spotlight here? If so, I'd like webpages I type in Spotlight to show up in Firefox. Also, it'd be nice if I could search my bookmarks from spotlight. These should probably be in a separate bug(s).

Comment 5

10 years ago
I should have added a <sarcasm> tag ...

But if you insists, see bug 293323.
(Reporter)

Comment 6

10 years ago
voted up. It goes nicely with the keychain bug 106400.

I'll confess, I meant this bug to be somewhat tongue-in-cheek. I won't be sad if this gets resolved wontfix.

Comment 7

10 years ago
I wanted a pony, so I typed "pony" in the awesomebar. I did not get a pony, just some links to some athletic clothing company and some _pictures_ of ponies.

I still want a pony, but I don't want a bug.

Help?

Updated

10 years ago
Whiteboard: [snarkfest][wontfix?]
This probably belongs in Shell Integration...

Updated

10 years ago
Flags: blocking-firefox3.5- → blocking-firefox3.5?
Not blocking. Still.
Flags: blocking-firefox3.5? → blocking-firefox3.5-
made a proof-of-concept extension that does this: https://addons.mozilla.org/en-US/firefox/addon/11378
(Reporter)

Comment 11

10 years ago
should add ~/Applications as well if it exists.

This works surprisingly well. Nice!
(Reporter)

Updated

10 years ago
Whiteboard: [snarkfest][wontfix?] → [snarkfest][wontfix?][loldietrich]
(Reporter)

Comment 12

10 years ago
also, doesn't work for apps inside folders. e.g., Photoshop\ CS3/Photoshop.app
Whiteboard: [snarkfest][wontfix?][loldietrich] → [snarkfest][wontfix?][loldietrich][icanhaspony?]
This is WONTFIX in core. Definitely should be in an extension, or as a feature in FirefoxOS a1.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: [snarkfest][wontfix?][loldietrich][icanhaspony?] → [snarkfest][loldietrich][icanhaspony?]
You need to log in before you can comment on or make changes to this bug.